E1Local not accessible during Deployment Server install

ericwood73

Member
When trying to install a Deployment Server on Windows 2012 R2 I get the dreaded "ORA-12514: TNS:listener does not currently know of service requested in connect descriptor" error. Both the TNSListener and E1Local services are running. When I run lsnrctl status, I do not see E1Local:
Code:
C:\Users\Administrator>lsnrctl status

LSNRCTL for 64-bit Windows: Version 12.1.0.2.0 - Production on 22-SEP-2017 19:43
:09


Copyright (c) 1991, 2014, Oracle.  All rights reserved.


Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=10.18.249.242)(PORT=1521
)))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for 64-bit Windows: Version 12.1.0.2.0 - Produ
ction
Start Date                22-SEP-2017 18:27:58
Uptime                    0 days 1 hr. 15 min. 11 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Parameter File   C:\Oracle\E1Local\network\admin\listener.ora
Listener Log File         C:\Oracle\diag\tnslsnr\jdemultidp1\listener\alert\log.
xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=10.18.249.242)(PORT=1521)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1521ipc)))
Services Summary...
Service "CLRExtProc" has 1 instance(s).
  Instance "CLRExtProc", status UNKNOWN, has 1 handler(s) for this service...
The command completed successfully
I also noticed in the alert.log file, I do not see any service_register messages, though I did see these in the standalone client install. I also confirmed the services were present in the DB:
Code:
SQL> select NAME from ALL_SERVICES;

NAME
----------------------------------------------------------------
SYS$BACKGROUND
SYS$USERS
E1LocalXDB
E1Local

I have taken a number of steps to address this:
1. Ensuring that the TNS listener service is running. I can tnsping E1Local just fine:
Code:
C:\Users\Administrator>tnsping E1Local

TNS Ping Utility for 32-bit Windows: Version 12.1.0.2.0 - Production on 22-SEP-2
017 19:42:08


Copyright (c) 1997, 2014, Oracle.  All rights reserved.


Used parameter files:
C:\app\e1dbuser\product\12.1.0\client_1\network\admin\sqlnet.ora




Used TNSNAMES adapter to resolve the alias
Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = jdemulti
dp1)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = E1Local)
))
OK (1150 msec)
2. Ensuring that the tnsnames.ora file has been copied to the 32 bit client bin directory.
3. Ensuring that the hostname is used in the tnsnames and listener.ora files
4. Attempting to force registration using alter system register.
5. Rebooted the TNSListener and E1Local services numerous times as well as manually starting these services.
6. Reinstalled both the E1Local database and the 32 bit changing the order of which one I installed first.
7. Set ORACLE_SID to E1Local
8. Added DBA_ORA group to my local user account (Administrator)
9. Followed the steps in this post https://www.jdelist.com/vb4/showthr...d-with-error-1?p=167628&viewfull=1#post167628
10. Used both 64 bit and 32 bit netmanagers to confirm settings and test connection (fails with same error)
11. Confirmed all my settings with my standalone client which has a working E1Local

At this point the only differences are that my standalone was installed using a domain user with admin rights, whereas my deployment server is installed by a local user with admin rights and the fact that I am installing a 9.1.0 deployment client versus a 9.2.0 standalone server, however I suspect the the E1Local setup is the same.

Can anyone tell me any other things to check or try beyond what I have already checked and tried?
 

ericwood73

Member
Alternatively, is there a way to skip the deployment server install altogether? Do I need it if I just want to set up a sandbox to test XML Interop with JDE? The problem is the database server install asks for details about the deployment server.
 

Soumen

Reputable Poster
"the fact that I am installing a 9.1.0 deployment client versus a 9.2.0 standalone server, however I suspect the the E1Local setup is the same"'

Isn't there this encryption change (Legacy to Enhanced) between 9.1 and 9.2 for E1Local? You can use the ReconfigureDB.exe from a 9.2 system to check/switch between the two. Just a thought because looks like your local db is set correctly based on the checks you have already done.
 

ericwood73

Member
Interesting idea. I'm not seeing any errors in the logs that indicate that the system can't log in, but maybe it happened during the install. My deployment server is a 9.1 release as fr as I know and it's installed from the same installer as the local database. Are you suggesting I try encrypting the password using the enhanced encryption?
 

ericwood73

Member
Got it fixed. It turns out that Oracle won't register the instance with the listener until you log into it with a user. Connecting as sysdba doesn't do it. I created a JDE user and then I could see the E1Local instance in lsnrctl status and access the E1Local instance.
 
Top