E9.2 Has anyone installed 9.2 Standalone on Windows 10 Home? Getting 'The command failed with error -1' on E1local

You sure you don't need to add a rule to windows firewall for 14501-14520 or so (or just turn it off to see).
You sure you don't need to add a rule to windows firewall for 14501-14520 or so (or just turn it off to see).
Well, TFZ, I tried a range from 14502 to 14530 and it didn't work, but of course I could have done something wrong...always possible! :)

I decided to take a step back and review what I've done so far (sanity check). I had to add some small things like add ip addr/machine entries to hosts files on all machines b/c att was appending their generic domain to my machine names via router/modem and it was showing up everywhere in JDE files and screens.

I've installed on Dep Server and Ent Svr - trying to settle upon a TR release I want to live with for a few months--since I am going to be piling many what I call extensions on (AIS, Transaction Mgr, etc) as well as test out some new CNC features-lots and lots of moving parts-there is a lot to take in. I'm also thinking of making a cheat sheet of known issues related to many basic steps for future reference (for example having to run installers with command lines syntax such as 'setup.exe -ignorePrereq ...' and 'setup.exe -preLoc C:\JDK...'); also pouring through the Known Issues list for recent releases ** JD Edwards EnterpriseOne Tools Release 9.2.x Known Issues and Workarounds (Doc ID 2062196.1)**
also documenting things I become aware of along the way, translating some topics into what I think is more understandable verbiage (generating site keys, throwing it into a 128 bit AES lockbox, even things like organizing the many downloaded JDE files and 3rd party apps I like to use like Notepad++ and DBeaver) Love the security setup though---talk about job security! Pretty soon E1 will be so secure no one will be able to access it or use it. LOL
Got it worked out! Had a brief chat with a new Oracle DBA buddy. The issue was I had to add/specify the entire FQN in tnsnames.ora - not just the machine_name - to the SERVICE_NAME! (as in 'machine_name.DOMAIN.COM) Grrrr! I knew I was missing one tiny detail. On to the next issue!
Oh yeah! PORTTEST SUCCESSFUL on Base System foundation against Oracle 19 db! (and yes JDE foundation STILL requires 32 bit driver - Oracle 12 32 bit - at this point) ..... TR update next to

I think I spent hours getting to where you were maybe 2 full pages ago :D Make no mistake, your effort here and documentation of it is fascinating and very appreciated even from someone like me who dabbles in the hardcore tech stuff but gives up when it causes too much pain :D
I think I spent hours getting to where you were maybe 2 full pages ago :D Make no mistake, your effort here and documentation of it is fascinating and very appreciated even from someone like me who dabbles in the hardcore tech stuff but gives up when it causes too much pain :D
Well like anything, some tasks go quick, some take days. LOL I was struggling to understand some quirks about Oracle db until I spoke to an Oracle DBA friend of mine who patiently explained (corrected) some incorrect assumptions - wishful but extremely LOGICAL! thoughts - I had about the behavior of Oracle db with regard to entries in the listener.ora and tnsnames.ora files. Also, I needed to get the order correct on which client connections to use because of multiple Oracle_Homes involved with such a config. I am documenting as much as I can too (including making VMWare back ups of each machine after work is done and completed successfully) which takes a lot longer than just running setup.exes and install.exes. I will have to organize all the things I came across in some logical fashion but only after I am completely up on 9271 across the board. It's taking me longer because I am taking care of boring domestic tasks and can't give the install full time attention. It will be another couple, three weeks probably of picking at it (because of other JDE CNC apps like AIS and Trans Svr I am piling on it) it is finished but I'm ok with it-I will still be all caught up on latest and greatest by then. :)
Well I figured out a major problem-why Agents weren't being recognized by Console in 9271 after decoding Oracle doc id on the issue--I will respond on my own post and share the wealth!....I didn't even have to call Oracle! :D -- also, I refreshed on how to DECOMPILE E1 Java code! VERY cool!
Hy Tiradoj,

where can we find wls 12.1.3? I do not see it on edelivery site. Also, have you had chance to document the steps? Appreciate your inputs till now
Hi Anand I do have a copy of 12.1.3 but it was not compatible with release of E1 I was going to (9271) so had to go with which is not officially supported either ( still is and WLS 14) but I felt it was close enough to work since I got 12212 to work on DEMO

By documenting the steps what do you mean? For installing DEMO on a laptop? Yes I did document earlier in this thread. If you mean for WebLogic specifically not really because the official Oracle documentation is 90% accurate in my unhumble opinion LOL I made notes on a couple of things to look out for but my hard drive died if you can believe it and I am trying to finish up the overall install at the moment. I will put together a list of gotchas and workarounds I had for full 9271 install but to be honest it could be a few weeks because I have a lot of loose information to recollect and sort through and put in some kind of order.
Yeah I was right!! NOTHING to do with Weblogic or needing a patch--a colleague suggested a problem with registry and so I dove in to compare reg entries

The problem is with the Windows Registry. JDE User Account Entries that are supposed to go into Registry are not being created fully.

I have to suss out my theory. I will give update if my workaround solution works
There's no part of logging in to a JDE web session that needs a registry entry if you're referring to the WLS getting a callobj connection but not finishing the login. However, don't want to steer you any further in wrong direction so I'm going to just go ahead exit stage left.
I have not said it is specifically about html client--it appears to be something about the way JDE user account is used during login process.

Short of me decompiling the source code, I am dependent on Oracle development to give a solid clear answer.

I cannot login to JDE FULL client except with JDE user. If I sign on with JTIRADO a JDE user account (not Windows) it does not update the Registry as it does with JDE.

I have a call with Oracle on issue and hope to find answer soon. Thanks.
Hello again all. Sorry to have disappeared: life happens while you are busy making other plans...lol

Apparently Oracle is stumped with my login issue as well.

I have a perfectly clean package build on, successful porttest and as I mentioned the user id JDE is the only account that I can sign into Dev client with. Still cannot sign into JDE dev client or HTML client at all despite a clean startup log and the fact my Health test runs successfully--I have successfully ran R0006P 4 or 5 times via health test and the report can be seen in Submitted Jobs

Oddest thing ever--no error messages, the sign on screen just disappears after hitting the F9000 task view table per the log and the HTML client just blanks the user id and password fields and doesn't even login.

I have tweaked many parms and settings to get clear logs. Pretty frustrating I must say.

I understand site keys are a requirement (from 9.2 or 9.2.1 on-depending on what paragraph from Oracle you read :D) but is password encryption also an ABSOLUTE MUST for all ini files for jde.ini, jas.ini, jdbj.ini, tokengen.ini etc - that is a lot of tediousness if so--I don't want to encrypt passwords on all those ini files because its a lot of unnecessary maintenance for my purposes (yes I know how to do it) and I don't need to do it--this is a test instance - no one is connecting to my home network whom I don't want to. There isn't any secret valuable company data on it anyway.

I am thinking the F98OWSEC is not being created in a way for JDE user to login. What's disappointing is the obvious
lack of error message/coding from Oracle development to give an idea what's up.

If it is improper site key/encryption F98OWSEC record the log should say so. :/

I am open to constructive suggestions.

I don't think you wou;d pass the health check with a bad site key / bad F98OWSEC record , it basically logs in and runs that stuff.
Does F9000 have a @JDE record (Task ID = @JDE), which is basically favorites?
Yes TFZ there is. There is also a record for @JTIRADO


and the login process APPEARS to generate a Favorite Task Id on the fly because the task id does NOT exist in the F9000. It is a different number/character set each time - it acts like it is finding or trying to create a favorite but I have not created any Favorites

The login process disappears right when it hits the F9000 table


For example this is the last action in JDE DEBUG above -- there is no such TASKID in table

SELECT * FROM TESTCTL.F9000 WHERE ( TMTASKID = '831D23CB-1A16-4622-97CE-41FAE1B265A8' ) in DBeaver:

Another thing I saw years ago...is when a user signs in a full listing of sub folders isn't created for JDE user in Registry under INSTALL.INI key

I don't remember what the problem was...

The full key entry structure is created for JDE but not JTIRADO

JDE yes