• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Submit an Interactive Application?

eydeak

Reputable Poster
We saw a new one today that has us scratching our heads. One of our production users somehow managed to submit an interactive application. We came into work this morning and this P55 entry showed up in work submitted jobs where it had failed because there were no specs.

We verified that it truly was an interactive application and not a misnamed UBE. We can go to the user's task view and run it fine. It's used all the time, been around forever and hasn't been modified in over 6 months.

It has only happened this once, so not a big issue. But we cannot think of a way JDE will let you submit an interactive application. Every way we can think of submitting a UBE, won't even let you select an interactive application. So, out of curiosity we are posting here to see if anybody else has ever seen this happen before.

Thanks,
Ellen
 

eydeak

Reputable Poster
The jde.log shows: Failed to load job spec cache for job 52584 report P554312A_DTZ0001. Cannot load specs for UBE.

Which makes perfect sense because there are no UBE specs by that name.

There should be a prize for the weirdest thing you've ever seen in JDE, shouldn't there :)
 

Larry_Jones

Legendary Poster
Rather than suspect the user I would suspect a developer created a "opportunity" that allowed for submitting a Application.
Either hardcoded or a variable submission?
 

johndanter

Legendary Poster
I'd agree with Larry.

Probably from a Business Function that's making the UBE name. Or just badly tested code that has got it hard coded.

Do you have old RPG developers there? :)
 

eydeak

Reputable Poster
I tried a couple of the BSFN's on Friday. Coded a quick test app that tried submitting the same interactive app. I couldn't get it to show up in work submitted jobs. It would hand and then fail on the submission. But, I only tried a couple of the BSFN's. There seemed to be a lot of them.
 

mdalton

Well Known Member
Ellen,

The metadata kernel must have experienced an error writing the spec files. The runtime cache is then not in a proper state. Based on your tools, there is a known issue for this scenario that Oracle fixed in tools 9.1.5.x.

Cheers,

Mark
 
Top