NER Copy

craig_welton

Legendary Poster
Hi folks,

I've had this little utlity in the toolbox for a while and wanted to make it public. I'm hoping you can help me test it out before I finalize it.

It's a simple dialog based app with 2 sections, source and destination. Find the BSFN object and function you want to copy in the source section. Fill in the Object, description and function details in the destination. Select the DLL and optionally the project to have the object appear in.

Notes:
Only for post XE releases.
The source object is what is in the local path code of the dev client.

if interested, let me know how it goes

thanks
Craig
 

Attachments

  • NERDup.zip
    24.5 KB · Views: 252

johndanter

Legendary Poster
It works fine :)
I'm on a test 9.1.5.3 TR too

It's been added to the OMW project I chose and compiles fine too :)

It needs all the values filled in before it enables the Copy Function button, but it works :)

Does it update the OMW tables in the background to show it's been copied and added to a project etc?

Can this do C++ too??
 

rev

Active Member
It looks like it worked fine for me too, the issue I have is copied new NER object token is with some other project and when I tried to it find the project name having the token there's no other project having the token object is present only in one project and now I cant do a check-out /check-in or delete the object. Not sure how to get the token now.
 

rev

Active Member
Ignore all my previous messages Looks like I found a small bug (Not sure If you call it one ), related to project name we can choose from NERCopy tool , it is being converted into upper case and this is causing the token issue. Please find the attachment.
 

Attachments

  • 6-19-2015 11-03-52 AM.jpg
    6-19-2015 11-03-52 AM.jpg
    17.6 KB · Views: 82
  • 6-19-2015 11-08-50 AM.jpg
    6-19-2015 11-08-50 AM.jpg
    24.5 KB · Views: 67

craig_welton

Legendary Poster
Thanks a lot. I'll tweak that. Also, I'm adding the ability to create a new data structure. Thanks to JMR for the suggestion.

Appreciate all the input,
Craig
 

craig_welton

Legendary Poster
Thanks for the input, here is an update. Fixes the upper case project issue and now provides the option to create a new data structure based on the source DS. All references to the old DS are updated in the new function.

As always, thanks for the feedback.

Craig

View attachment NERDup.zip
 

craig_welton

Legendary Poster
Yes, but not all at once. Select an internal function, one at a time, and copy it to your new BSFN object. The point is, you have to rename each function you are copying. Just reference the same new BSFN object and they will appear within that same object.

Craig
 

Deepesh

Active Member
Thanks a ton Craig. We used to open the xml and modify it. Any place where you'd miss it, would be a corrupt file. This works seamless.

It always amazes me, how do you connect to E1 from outside.
 

Neal Scarr

Active Member
Hi,

I have been using NERDup sucessfully for months on my Windows 10 E1 9.0 9.1.5.3 PC. (great tool by the way!).

Yesterday I installed the Windows 10 Creator Update and now when I try and run NERDup I get the error "The procedure entry point [email protected]@[email protected]@[email protected]@@@Z could not be located in the dynamic link library C:\E900\system\bin32\icui18n.dll".

Has anyone else had the same problem? Is there a fix?

Neal
 

vaneldas1

Member
Hell Craig,
The tool is so awesome. I have just tested it and it is working perfectly good.

You are too genius. I am great fan of you.
 

johndanter

Legendary Poster
Hi Craig,

Not sure what's going on but I've this before and on FAt client it seems to work ok but on the other it says its missing file mfc140u.dll....................Odd thing is this file isn't even on the other FAT client?? :)
 

craig_welton

Legendary Poster
Yes, it was built with Visual Studio 2015 so that is required. There is a link on the download page, under requirements.

thanks
Craig
 

Neal Scarr

Active Member
Hi Craig,

I've just installed the latest version of the Microsoft Visual Studio 2015 C++ Redistributable Package and I'm getting the same error as John - missing file mfc140u.dll. I'm running NERDup on Windows 10 Enterprise Version 1709 OS Build 16299.64.

Neal
 
Top