JDE Deployment Server / Server manager refused to connect

James Monroe

Active Member
Good day, I have reviewed past messages and cannot find anyone with this issue that might help. Here is our problem. We are on E1 9.0, tools, by the way.

This past Friday we had an issue where the operating system on the JDE deployment server, JDEDEPLOY, apparently froze up. This was what was told by our now 3rd party hardware hosting service. The symptoms were that you could not connect to JDEDEPLOY from windows file explorer, and the JDE Server Manager link no longer worked when you tried it, although you could remote desktop to it.

Our 3rd party hosting services restarted JDEDEPLOY, and that appeared to correct things such as accessing its folders through windows explorer or other processes.

However, when trying our link to the JDE Server Manager, it does not bring up the server manager login, but after a minute shows the error, This Site Cannot Be Reached JDEDEPLOY refused to connect. See the attachment.

The actual link is jdedeploy:8999/manage/home

If I take this link from any browser that is logged into our network, including connection by VPN, this should give you the server manager login. Since the server was rebooted to correct the 'Frozen' OS, it gives the refused to connect message.

Note that last weekend we moved all of our production servers to this 3rd party service and hosting site. Our IT is saying that the 3rd party is now responsible for this server, and the 3rd party is saying its not an actual hardware problem, so they will not look at it. We did have quite a few issues with many systems including JDE over last weekend as they moved our prod servers to this site. But everything has been working fine all week including the deployment server, until this event this past Friday.View attachment JDEServerManagerError.doc

I'm a the only jde developer and do basic cnc tasks, but not sure where to even look. This has never failed with the deployment server is actually up and running. We had issues moving production servers to this 3rd party size last weekend, but the JDE Server Manger link was working fine until this 'Frozen' OS event.

Any suggestions as to where to start looking would be appreciated.

View attachment JDEServerManagerError.doc
Last edited:
James this could be a bunch of different things, from the server not even starting (do you see a java.exe running in task manager) to ports being blocked (does localhost:8999/manage work from the server?) I *think* it should be weblogic by now, does http://localhost:7001/console bring anything - again while on the dep server itself. If it runs local - you can check for ports being blocked. If it's not running at all, see if starting it from the weblogic console helps. You also may want to delete your cache / temp folders under the weblogic domain folder. Hopefully any of this helps. If ports are blocked, your hosting partner will need to help with firewall rules. Paping is an excellent tool to test to see if ports are there and open (google it.)
Hi James, another possibility is that it's the way the local Oracle database encrypts its passwords. When moving a server or fat client to a new machine, you may need to run reconfigureDB.exe for tools 9.2, or reconfigureMSDE.exe on older tools releases to reset the passwords. Search JDELIST, the internet , or My Oracle Support for the details. Good luck!
Thanks for the suggestions. First thing checked is Task Manager, and there is no java.exe running. Trying http://localhost:7001/console says 'This page can't be displayed'. Your weblogic mentions confuse me a little bit. I'm not a CNC guy but I always think of Weblogic running on our Web Servers. We have three, two run weblogic that are load balanced for Production, and one that is used to connect to our DEV and QA environments. I guess I never thought of weblogic running the deployment server, or is that how the JDE Server Manage is access? my ignorance.

That is what I've had a chance to check so far.
One other note/clue, I did open a ticket with Oracle and they have requested the e1agent* logs. I forwarded them to them, but did notice that we have e1agent logs daily or a couple times a day going back to 10/13, but none since 10/17, which is the day we lost access to the server manager. So sure seems like something is not running.
Tools 9.1.4 would be running Server Manager using the OC4J, so I don't think any WebLogic should be in play.

Since you mentioned you don't see any java.exe in task manager (make sure you are looking at processes from all users), check that your SM Console service is running. Check the services on the Deployment Server and you should see a service called "SM Management Console" or something along those lines. If it is showing as stopped then start it and confirm you see a java.exe*32 in task manager. If you do, then try the login page again.

If it still fails to load after the above, also check that if you open a browser from the deployment server itself, if you can open the login page.
Thanks ice_cube. When I check services, I see two like that name.

SM Management Console [D:\jde_home\SCFMC] - SCFMngmtConsole2
SM Management Console [D:\jde_home] - SCFMngmtConsole1

Both are not started, status is blank.

Trying to Start the first one (the one that says Console2) I get a message that the service Started, and then stopped. Some services stop automatically if they are not in used by other services, it says.
Trying to Start the second one (Console1) gives me an error the system cannot find the file specified.

As to trying the browser on the deployment server, It says page can't be displayed.

Corresponding with Oracle now on this as well.
Hi James,

That would pretty much be the crux of your issue. Your SM Console service is not running. Without looking at your system I cant easily tell which service is the correct one but I think it is the SCFMngmtConsole2 based on the path , but Oracle Support should be able to help you figure this one out, let them know the SM console service is not starting up. You could have missing files, java could have got updated, etc. The log files may have the answer. Do you have server backups from prior to the "freeze" event?

Good Luck
Thanks all. Had to reinstall the SM management console on our deployment server. Back working again now. No clue as to a cause though.
Thanks all. Had to reinstall the SM management console on our deployment server. Back working again now. No clue as to a cause though.
Having a similar concern with the service. So what was the procedure to reinstall it unless some ways to reconfigure?