• Welcome to the upgraded JDELIST forum and thank you for your patience.
    Please restrict discussions and issues regarding the new forum software to the Off Topic forum. We will be monitoring that forum for issues.
    If you have trouble logging in, please reset your password using the forgotten password form: https://www.jdelist.com/community/index.php?lost-password/
    If you are unable to successfully reset your password, please contact us: Click here!
    We hope that you enjoy the upgraded forum.
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

ER Debugger - Invocation Error

We have been having problem with our ER Debugger when debugging APPLs. It seems when we put a breakpoint in some spots (Like the OK button or Dialog End) the APPL just hangs and finally in the ER debugger we get an error message "ResumeProcess invocation Error. 0x1 (no response).". See the attachment for a screen shot. At which points things are pretty much dead. We have had this in muliple APPLs in different unrelated processes. I think it happens when a called form returns to the calling form (that has the breakpoint) and the Ok button is pressed or the form is closed via code instead of a user action. Not sure but I think that is the common thread.

Before I contact Oracle support and embark on a lenghty process that will consume the next 8000 hours of my life has anyone else encountered this?
 

Attachments

B,

Yes - I regularly see the same (or at least similar) issue. Due to the issue, I've rebooted machines machines so many times I have wear marks on the Start button...

Please let us know if you find anything useful!

(db)
 
Does rebooting solve your issue, at least temporarily? From what I am seeing I can't find any way to get past it. One of my developers had to use MDDebug, logging, trial and error, etc. to fix something which turned what was probably a 30 min fix into a 2 day event.
 
B,

Rebooting and refreshing the DIA - seem to resolve most of the issues I've been experiencing with Debug, lately. The issue I experience may be slightly different from that which your team is experiencing. I'll write down the actual error message, next time.

I am aware of a developer that, despite everything we have tried, still can't get Debug to work with one specific report. That developer, also, had to resort to M&D Debug...

Oracle - can we have a debugger for your debugger?

(db)
 
We actually had this problem (the problem defined in the article you referecned) as well a long time ago and we have applied the manual fix (rename/delete soap.jar). Without this fix we can't debug at all, now it just happens when breakpoints are set in certain places on certain apps.
 
Boster,

This is something I got from our CNC guru...

E1: BSFN: ER Debugger Does Not Work in Tool Release 8.98.4.1 and above [ID 1301062.1]

don't know if this applies to you...just to let you know.
 
Thanks, actually we had this problem on 8.98.4.0 (we couldn't debug at all). When we applied the fix (rename soap.jar) it solved our issue for the most part, however, we still see situations where the debugger crashes and we can reproduce the crash as well, so its not some sort of sporadic issue.

I have got a call open with Oracle, so we will see...
 
This seems quite an old thread, if someone is checking here be aware that, not sure about previous version but from 9.0 and above, i guess this issue and most other debugger issue should be solved by just closing Launch JVM.exe process and few other java process in the task manager, this will help clear this issue most the times.
 
If debugger gets any kind of issue and then you try to use it , the debug points are never hit again , debugger has been having this issue always . The resolution is to sign out off jde , kill active console , kill java.exe and all that and try . If that does not help , then restart machine and that will reset debugger back . Always validate your event rules first as well to make sure we are clear on that side and those are validated before using debugger . Try commenting the code on that button for the specific case and see how debugger behaves
 
Top