Same UBE - Different behavior Fatclient/Enterprise

mvolpe

Member
Hi,

I ran into a very odd issue recently, I have a fully customized UBE which gives me a pdf with all the records it added to another customized table and what wasn't added and why.

Every day it runs through JDE scheduler and every day I get a lot of errors that doesn't make any sense, so I ran in my fatclient to debug and try to make sense of those errors. Now is the odd part, when I do that, it runs clean, no errors, it's the exact same report in my fatclient.

I wonder if anyone here has seen this kind of thing, and if so, what did you do to make it work properly.

I don't know if it's relevant, but what the UBE is doing is simply reading receipted costs, adding to a work variable for it be checked against the supplier's voucher total later, if there's a difference I'll roll back everything of that order and show an error message in the pdf, but I only get these erros when I run in the enterprise server, have anyone see something like that? I'm running out of cards here =(
 

johndanter

Legendary Poster
This could be down to many reasons. Off the top of my head:

What does your error say?

1
There's a client only BSFN in the code? Maybe the validate UDC one B9200017.

2
Specs for some objects in the chain are not on the enterprise server but on your local machine

3
Asynchronous processes. running local in debug is usually slower

4
Your local FAT OCMs are pointing to a different datasource than the UBE is

Post the code
 

mvolpe

Member
Hi John,

It's not a UBE error, it's a business rule error, the UBE runs successfully, but it behaves differently when I run it in the enterprise, it's a pretty simple straight forward program, nothing fancy.

1. No client only BSFN, I'm using a UDC validation but it's the B76V9200.

2. I think they're the same on both sides, otherwise it would end in error, wouldn't it? Anyway, I already did another package and submitted the version specifications only to the enterprise, but no success.

3. This is probably it, from what I see, it seems that when it runs in the enterprise it's so quick that it skips records, but I don't see any asynchronous process, but I may be mistaken, I'm uploading the code either way.

4. No OCM datasources overrides either.


The error happens when these two work variables are different: rpt_SumDetailAmount and rpt_SumAmountGross, but the thing is they shouldn't, at least not on most cases, when I run on my fatclient the same order that gave me an error in the enterprise, it runs clean, no error.

Thanks,
 

Attachments

  • R5504004.txt
    33 KB · Views: 15

jimjung27

Active Member
Is the Process Location setting on the Category Codes tab of the UBE in OMW set to 2 - Both Client and Server Function.
 

jimjung27

Active Member
If you submit the UBE to Enterprise Server with Logging (JDE.log), Tracing (JDEDEBUG.log) and UBE Logging Level 4-6, you should get the Log for that UBE in Submitted Jobs. Choose View Logs instead of View PDF from Submitted Jobs.

This would show you the error message from Enterprise Server but the log may be long. If you use the correct Logging Level, the Log will display the ER Code lines which would may it easier to find the error.
 

johndanter

Legendary Poster
Yeah you need to post the log mate.
What data type are those 2 variables? Size etc. Are they big enough?

First thing, this doesn't look right to me

0002 Set User Selection(BC Numero do Voucher JDE (F55JPFSI)(55NUFAN8), <Equal To>, <Zero>, <None>)
0003 Set User Selection(BC Void Flag (F0411)(VOD), <Not Equal To>, "V", <None>)
0004 Set Selection Append Flag(<Yes>)

There should be an OR or an AND there somewhere, no?
 

jimjung27

Active Member
The Enterprise Server is not as forgiving as the Local FAT Client. Your FAT client will let go the error below but the Enterprise Server will not and a different result will created. I think if you change the <None> in the firswt two lines below to <And> or <Or> then the results will be the same on both FAT and Enterprise.

0002 Set User Selection(BC Numero do Voucher JDE (F55JPFSI)(55NUFAN8), <Equal To>, <Zero>, <None>)
0003 Set User Selection(BC Void Flag (F0411)(VOD), <Not Equal To>, "V", <None>)
0004 Set Selection Append Flag(<Yes>)
 
Top