• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

QBE in Enviroment

jberry

Member
List,
When looking at one of our environment, some of the QBE lines are graded out where we can not use them. But, if we go to out Prototype, Developement, and Production environment they are not graded out.

Is there a OCM mapping or setup that we may be missing?

JBerry
OW XE SP16
AS/400 - ES
Windows NT - DP
 

Zoltan_Gyimesi

Legendary Poster
Hi Jimmy,

You are right. This is generally an OCM issue.
Check all TBLE Object Type entry in OCM for your environment where QBE is grayed out. Check first the DAFAULT, *PUBLIC entry.
Verify the "Allow QBE" settings on the bottom of Object Mapping Revision screen. The valid values are in UDC 98:QB
1 All QBE Allowed
2 No QBE Allowed
3 Indexed fields QBE allowed
Hope, could help.
Regards,
Zoltán
P.S.: You have to log off / log on OneWorld to take effect OCM changes!

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

jberry

Member
While I was at lunch discussing it with the CNC guy, it hit me that there is a Allow QBE function in the OCM's. For Business Data it was set at 3 - Index only.

Thanks,
Jimmy
 
Top