• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Install Object

Frosty the Coder

Legendary Poster
Currently, we are in the "busy season" and are _not_
in a position to to a package build. "No how, no way."

This being so, we _have_ had luck, implementing
to FAT clients, by doing check out/erase check out
through OBJECT LIBRARIAN.

Today, we are trying this w/ a CUSTOM ube that
has views and p/opts to it. This ube has been
modified, and we are trying to get the mods
onto our "RUN IT FROM HERE" fat client.

It's _not_ picking up the mods.

Prior to today, on this list, I'd been told that
INSTALL OBJECT would work as well, if
not better, than the check out/erase check out.

What is the name of the INSTALL OBJECT app
and which menu(s) is it accessable from?

TIA




Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
 

Zoltan_Gyimesi

Legendary Poster
Gene,
Install Object is available in the Row menu of Object Librarian after you have selected an Object. If I am rifght, it is available only for APPLs and UBEs.

On the other hand:
1.) How have you detected that you haven't got the mods after Check Out? Have you Checked Out the object anyway?
2.) Are all modified and required objects Checked In?
3.) Have you Checked Out all required Objects? Have you do it from the same Path Code where the modified objects have been Checked In?
4.) Have you made the mods on the template or on the version? In the first case, have you create a new version (via ADD, not Copy)? In the second case, have you checked out the version too?
etc.

Please, let us know if you still has the problem and apply us with more informations.

Good luck,
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 
G

Guest

Guest
If you are running the version from the Enterprise server you need to submit
the specs. It is an option when you submit the UBE and it just submits the
spec files for the version and does not run the UBE. Then all your users can
run it (if they checked the version into their local machine.

Crawford
 

Frosty the Coder

Legendary Poster
Zoltan, the answers to part 2 are:

1: The mods I made reduced the report output from 14K+ pages to 44.
This doesn't happen at the target. This is controlled by p/opts which
I suspect are not being "seen".

2: I checked my stuff in from the development machine.
I've made the oversight mistake before and have gotten (pretty) good
about getting them all, at least after the first oversight.

3: The owner of the target client says he checked them all in. I'm not
on
site to verify.

4: Changes were made to the template. Afterward I checked in the version
as well. At his client, he checked out the template and then the
version.

At your suggestion, I've asked him to create a NEW version (add, not
copy)
but he hasn't gotten to do that yet.

Why wouldn't checking out the mod'd template AND the mod'd version
work?
I've seen this phenomona before and the add, not copy, _did_ work.
Why?

Thanks for help.

Please don't ever go away.....



Gene,
Install Object is available in the Row menu of Object Librarian after you
have selected an Object. If I am rifght, it is available only for APPLs and
UBEs.

On the other hand:
1.) How have you detected that you haven't got the mods after Check Out?
Have you Checked Out the object anyway?
2.) Are all modified and required objects Checked In?
3.) Have you Checked Out all required Objects? Have you do it from the same
Path Code where the modified objects have been Checked In?
4.) Have you made the mods on the template or on the version? In the first
case, have you create a new version (via ADD, not Copy)? In the second
case, have you checked out the version too?
etc.

Please, let us know if you still has the problem and apply us with more
informations.

Good luck,
Zoltán




Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
 

Zoltan_Gyimesi

Legendary Poster
Gene,

Why does "Add Version, not Copy" work?

It seems to me so that if you have ever touched a Batch Version (PO settings, Selection, Sequencing, Design, etc.) then it becames a "snap-shot" on the template, punctually on less or more part of the template, based on the type of touching.
After it happened, many of the changes made on the template won't be transparent for this version any more.

Regards,
Zoltán


B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

Frosty the Coder

Legendary Poster
I wish I knew why, in that particular case, "add, not copy" worked.

I _think_ the circumstances were that I was trying to get
changes made by an esu to be picked up. I remember
working w/help desk who eventually suggested ADDING
my new version rather than copying it from the XJDE0001.

As w/most issues, as soon as it was resolved, it was
no longer a problem and I had to move on to the next
crisis (which there have been _no_ shortage of).




Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
 
Top