• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Create new email body( glo E ) and replace the old email body in a RD.. but nochange

Hi :

first, I am very new in JDE E1 910. sorry if I ask easy question.

In fat client, I create a new email body call 55T06 ( through data dictionary design > Error Messages ) in DV. I confirmed the 55T06 is also created in web client ( the lead developer told me this 55T06 will automatically popular to PY and PD ). In my next step, In both OWM and Web client, I replaced the old email body by this new one 55T06 ( though the report definition > Data Item for Subject and body to 55T06 ).

At first, during my unit test, the email I received still have the old email body. I did few time by changing status from 26 to 21 then 21 to 26... even have the CNC guy to "clear the cache"... then finally.. it suddently work. So I though the root problem is due to clear the cache.

Now, after the weekend ( the server crash too ). I run the same Report again... and again, receive the old email body.

How come? Any idea where could be the issue. any idea help

Fsldiscover
 

Larry_Jones

Legendary Poster
"... through data dictionary design > Error Messages ..."
Is this supposed to be an error message? I think you should be defining it as a Data Dictionary Item
 

jdedwardsuser

Active Member
So basically you are trying kind of template substitution with RD by creating a DD item (error message will work, we use and it works in our multiple cases ) make sure its type is warning and then lets say , in the subject line you have &1 and then body you have &2 . Now in the report which is BI modified , you have RV variables which are getting these values . On RD , you have data item for subject and body , associated it with the DD item , then click on map values , then provide the mapping to this DD item . Of course DD item in order to have template substitution like this needs a DSTR attached to it as well which is defined in DD item only .

If you are not doing this and it is a static DD item created , then probably no need of DSTR , no mapping RD , try doing an update package of the entire project . If it does not work , first ask CNC to clear all runtime cache , which includes UBE , UBE version cache , etc , also try sql packages , try removing the 6 dddict files as well and then try again . If all else fails try a full package to tie all things together .
 

johndanter

Legendary Poster
Is this on your FAT machine or the server it's not working?
If it's your FAT, try deleting your DDDICT DDTEXT files etc. If it's on the server.....speak to CNC about that
 
thanks for all your help. I finally find an answer from one of the post in my oracle support. I don't know the real reason... I was told if I update the existed email body ( glo E ), I will have to build the package and promote it, then it will fix it. That work for me
 
Top