Changed a report template and definition, now it won't process to BI

  • Thread starter Frosty the Coder
  • Start date

Frosty the Coder

Legendary Poster
List - I am proof positive that "a little knowledge is a dangerous thing".

I had a BI template and definition that needed a tweak.

I deleted the "Report Definition" via P95620.

From P95600, I downloaded the template, made a formatting change, and uploaded the template.

Back in P95620, I copied a different "report definition" that was attached to a different version
of the same UBE, and pointed at a different template.

I selected the newly created "report definition" and adjusted the UBE|Version and template to what I needed.

I compared the two entries, and they match except for the version name and template name.
In both cases "Blind Submission" is checked.

I did a "submit" on my newly added definition.

When I run the "copied from" template/defintion, which is launched from an application,
I am NOT prompted for output destination, XML is generated, and BIP properly formats the PDF.

When I run the "new" template/definition, launched from the SAME application,
I AM prompted for destination, do NOT get XML, and only get the unformatted PDF.

I have performed these steps numerous times, hoping to see why they act differently.
This has included signing off, and trying from a different machine.

I read the BIP manual looking to find my oversight.

Can anyone point me at what I may have missed that my new template/definition isn't working.

Please and Thanks
 
This may be a stupid question. Did you go to the report version you are running and check it out, go to Row|Version Detail and Form|Report Definition to update the Report Definition on the UBE side?

Ben again,
 
Honestly, no we had not tried that, but I will in a few minutes.

I also found, in the Oracle "Community", a couple statements that
there's a setting in the BURSTING tab that needs to be set.

(Although copying from one that works should have picked this up.)
 
"Ahem"

[size=+2]WOOHOO![/size]
It's "unbroken" as far as PROMPTING and RUNNING THROUGH BI!

Now, I have to figure out some goofy formatting, but that part is doable!
For what it's worth, I didn't see this step in the documentation.
 
Good to know you are working! Not sure what documentation you are using, but here is a quickie (from I believe Jay Vickery, but if someone else deserves credit let me know) that I keep handy. Also Scott Beebe has a great paper on the process - much more in depth (you can web search it).

Ben again,
 

Attachments

  • BI_Cheat_Sheet.pdf
    6.5 KB · Views: 72
Thanks AGAIN!

Now, another question - one of the environments is giving an error, w/in the UBE Details, that the report definition isn't found.
The FC showing the value is disabled, so it can't be changed.
If I use P95620 to delete the RD that is says doesn't exist, will that enable the FC and allow me to correct this?

(I think SO, but thought I'd ask).
 
We found that we were able to SQL the correct value into the VERSIONS and/or VERSIONS-TAG tables (F983051, F983052).
Thanks for your help.
 
Back
Top