E9.1 CGI R744003 BIP XML template issue



I am implementing the CGI functionality (Common Global Implementation ISO20022) in JDE 9.1.5.
We installed the corresponding ESUs and set up the configuration for the processes.
The object R744003 has associated a report definition RD744003 to the JDE standard version ZJDE0001, but it does not exist in our environment.
We were able to run the process associating a blank template but due to this issue I don't get the xml file in the final format ISO 220022.
I would really appreciate it if somebody could send me the template or let me know where I can download it or any support on it. :)

Thank you in advance for your help!!
Last edited:
Hi Marta,

that doesn't work that easy. You have to create your own custom setup for that, since the default xml template won't be accepted by your banks.
Create your own version of R744003 , link that to your own Report definition and template. Then you download the default template from JDE and adjust it according
to the documentation of your bank.
Thanks for your quick answer Delvern!
I do not have the default template in the system. So I associated a blank template to get the the xml RD source. Example of part of the xml:


Could you please clarify if I should build by myself the template from scratch?.
Thanks again!

JDE has a default template already configured, which however never has never worked without adjustment for me.
You get it from P95620 > search for UBE R740003 > enter the RD and look for the template > go to P9520 look for the template > row exit > download
You get the xsl file which the BI publisher uses to transform your source file to the output xml payments initiation file.
Let me know how it goes
Thanks Delcern!

The issue was that for some reason the default template was not installed together with the ESU JM22856, despite of all the reports for the ESU installation - R989200P, R9690002O, R98405, R98403XB, R98700, R9870 and R96956202 - successfully run. After some checks with Oracle support, they recommended to uninstalling and reinstalling the ESU, and it worked!