• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

BI Pub PDF output shows "?" instead of diamond-shaped checkbox

DSauve

Legendary Poster
We are upgrading to apps 9.2 with tools 9.2.2.4. In our testing, we have run a standard JDE Health & Safety UBE to generate the OSHA 300 report. It runs fine on our 9.1 production system, but in our 9.2 system, the diamond-shaped checkboxes are showing as a large question mark "?". The real interesting thing is that if I generate the PDF output from my BIP Desktop, the diamond-shaped checkboxes appear as they should -- so the problem is only on server-processed jobs.

Any suggestions would be most welcome. Thank you.
 

DSauve

Legendary Poster
Ok, I'll provide the answer to my issue (thanks to Oracle support for coming through!).

I had to copy the ALBANWTJ.ttf font from C:\Windows\Fonts on my BIP Desktop box into the ...\E920\jdeJre\lib\fonts folder. (Actually I copied all the ones that begin with ALBAN -- 5 total). You can also refer to Oracle Doc ID 874194.1 for additional information.

Now I get my diamond-shaped checkboxes to appear just fine!
 
Last edited:

llallen1113

Well Known Member
We had a similar issue with bar code fonts during our 9.2 upgrade. Silly ttf files will get you every time there is a new batch server unless someone copies them over.
 

DSauve

Legendary Poster
The weird thing is that with tools 9.1.5.3, we didn't have to copy these font files to the batch server. My guess is that in the older version maybe it was using the fonts installed in Windows, while the new version looks in the specific jdeJre\lib\fonts folder.
 
Top