• JDELIST is celebrating its 20 year anniversary today!
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

UBE ending in Error AS400

mezereo

Member
Hi,

Let me start with saying that I'm new to RPG programming and AS400 systems.

We have a custom UBE which ends in Error when run on the server (AS400) only for a particular order number (runs without any issues for all other orders). For the same order number, it runs fine when run in LOCAL.

The jde logs dont have any information regarding the issue/error but I found the below error in the AS400 job log:

40 24/12/14 21:0:49 JDEKRNL B7334SYS *STMT JDEKRNL
B7331SYS *STMT JDELIB B7331SYS *STMT
From module . . . . . . . . : JDECM_RB
From procedure . . . . . . : RBTREE_FindPtr
Statement . . . . . . . . . : 1
To module . . . . . . . . . : JDECM_RB
To procedure . . . . . . . : RBTREE_FindPtr
Statement . . . . . . . . . : 1
Message . . . . : Pointer not set for location referenced.
Cause . . . . . : A pointer was used, either directly or as a basing pointer, that has not been set to an address.

We tried to restart the services, submit the UBE specification on the server but nothing works. Interesting part is, the UBE does end up successful once in a while for this order number.

Any ideas/pointers on where else to look for this issue.

Appreciate any help or guidance.

Thanks,

B7334, SP23, AS400
 

mezereo

Member
We enabled the jde debug and found out that it is failing at a point where the program is trying to insert into a table. Checked the AS400 job logs and found below entries:

Message . . . . : Pointer not set for location referenced.
Cause . . . . . : A pointer was used, either directly or as a basing pointer, that has not been set to an address

Message . . . . : The pointer parameter passed to free or realloc is not valid.
Cause . . . . . : The pointer parameter passed to free or realloc was not valid. This caused your function call to fail.
Recovery . . . : Correct the invalid pointer parameter being passed to free or realloc.

Message . . . . : The requested heap space operation is invalid.
Cause . . . . . : The requested heap space operation is invalid. The heap space identifier is 0. The activation group mark is 17. The activation group mark will be zero if the heap space is not associated with an activation group. The error type is 2. The error type indicating why the heap space request is invalid is defined as follows: 0001-Attempt to destroy the default heap space; 0002-Attempt to free or reallocate heap space storage that is not allocated; The heap space identifier and activation group mar may not be valid for this error type; 0003-Access to the heap space is no allowed; 0004-Attempt to mark a heap space that cannot be marked;

Every time we try to debug, got a new error in the AS400 job logs.

Thanks,
 

DBohner-(db)

Legendary Poster
Howdy,

Are you running an RPG pgm or a JDE UBE?

If UBE - what happens when run locally?
Have SQL Packages been cleared, recently (I hate what those things do to debugging)

Insanity.... Doing the same thing over and over again, getting a different answer each time.... You Are Insane!

(db)
 
Top