• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

SVR replacing "P" with "7"; "R" with "9"; etc

Frosty the Coder

Legendary Poster
It's late in my afternoon, and I've just broken SVR.
It had been working most of the day, but SOMEHOW, I fat fingered SOMETHING, and am now SOL.

If I inquire on member id = P4210, when I press enter, the member id changes to 7,4210.
P4111 changes to 7,4111.

If I inquire on R0005P, member id switches to 900,057-

The member description isn't hosed, but the "Function Code" (RPG, DDS, etc) isn't working.
F1 to get field level help isn't working either.

It FEELS LIKE "member ID" is being scrubbed as a numeric. But that's just a feeling.

I've rebooted my machine, compared my user profile to that of another developer, looked at CCSID, Language Preferences, etc
but am NOT seeing what may be causing this.

I know it is being set when I sign on, as when I first noted it SOME of my sessions worked (until I signed off).

I don't know whether I've got an issue w/in JDE, or if it's at the OS/AS400 level.
I just know that I've got a NEW, EXCITING issue to dig at.

Thoughts?
 

Frosty the Coder

Legendary Poster
Further testing shows that this isn't limited to SVR.
If I go into address book maint (P01051), key address book 123456, and press enter, AB# gets edited to 123,456.
AB# has an edit code of "Z" so this shouldn't happen.

ALSO, besides being "just me", this is "just in DEV".

Grrrr
 

G_Smith

Well Known Member
My first question is what is the client program you are using to access the system? Is it Client Access/iSeries Access for Windows or some other brand of 5250 Emulation? Or are you trying to use the Web Client that JDE provides where you use either Java or ActiveX to present the JDE processing? I seem to remember that Oracle recommends not using the Web View process with the SVR and SEU editor but I may be wrong. Have you tried other non-JDE programs to access the data such as Query, STRSQL, or DSPPFM?
 

Frosty the Coder

Legendary Poster
One of the "life lessons" I've learned is that "if you ignore a problem long enough, it MAY go away".
(It may not, but the approach is worth trying)

In THIS CASE, the approach worked.
I took a couple of days off, completely, no remote access or ANYTHING, and TODAY, the problem has gone away.
YAY!

I suppose that I SHOULD CARE as to what the issue was BUT, being Monday, I can't bring myself to do so.
Oh well.

Thanks to BOTH George and Terry for the suggestions.
 
Top