• Welcome to the upgraded JDELIST forum and thank you for your patience.
    Please restrict discussions and issues regarding the new forum software to the Off Topic forum. We will be monitoring that forum for issues.
    If you have trouble logging in, please reset your password using the forgotten password form: https://www.jdelist.com/community/index.php?lost-password/
    If you are unable to successfully reset your password, please contact us: Click here!
    We hope that you enjoy the upgraded forum.
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

SP23_K1 and Vertex

jimmymac

Member
We are on OneWorld XE SP23K1 and are trying to set up Vertex, using the Embedded SQL version. What we are unable to do is perform the P73GEO test successfully. We can connect via the Windows and AS400 tests but not from OW. We have gone over all of the recommended checklists and still no go.

A little background, we actually did successfully get SP23R1 and the CLI version of Vertex to work. Great we thought. However, it basically shutdown our operations system which is an RPG/JAVA inhouse system that interfaces with JDE via SQL. The sql server mode of SP23R1 essentially hoses the SQL connections apparently. So we have no option but to roll back to K1 and try to get vertex to work with it.

Any ideas would be appreciated.
 

markdcci

Member
jimmymac,
We were on Xe, SP23_K1 and Vertex 2.0.15 for quite a while. Those two played OK, except we also had sporadic problems (e.g., tax inexplicably not calculated for one entry, then calculated fine for the next entry). We attempted to upgrade to the version you are probably looking to implement, 3.2, along with SP_R1. Enabling CLI not only caused Vertex bsfn's to stop working but also caused all bsfn's to not run on the AS400. It did not happen right away and did not show up in our testing, but after about 12 hours into production our web users and Vertex users were dead in the water. Although it does not appear to be documented anywhere, the response line told us how to shut off sqlserver mode and we had to downgrade back to Vertex 2.0. They told us no one else was having this problem, so we are awaiting a resolution. This was probably the nastiest service pack experience we have had in the last few years, and we have had some nasty ones.

Sounds like you are in the same boat.

One thing I did notice is that, when doing the Vertex install you could choose between the DB2 version and the CLI version. Not sure if the DB2 version would work with sqlserver mode disabled, but you may want to try that in a test environment.
 
Top