• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

RDA Spec Problem

Toni_Nanneman

Active Member
This just started this morning...
When we attempt to check in versions to PROD or transfer UBE's to PROD, the
process locks up on transferring RDA specs and we have to kill the OW
session. Other objects transfer just fine.

Any ideas? I'm guessing corrupt RDA specs in PROD but what do I do about it
or how do I confirm? Your comments/suggestions would be greatly
appreciated.

Toni Nanneman
Holiday Retirement Corp.

OW B7322 sp12.2; NT SQL 6.5 Deployment Server; Coexist A73 cum 8; 400
Enterprise Server



B7322 SP12.2; NT; SQL 6.5; coexist on AS/400 with A73 cum 8
 

Mike Mackinnon

Well Known Member
I don't know if this helps any but we have similiar problems. We are working on a network where we have a slow line (remote server couple hundred KM away) and sometimes the object librarian may lock up when checking in large objects to the server.

Our technical people say that this can happen if there is a "bump" or "glitch" in the communication line. The objects usually always transfer (if you wait a while before killing session) but sometimes as you say "the process locks up". Maybe this can give you an idea. What kind of system are you guys working on?

Mike MacKinnon

Mike MacKinnon
- One World B733, SP 11.3
- One World Xe B7333, SP 13 Windows NT
 

Zoltan_Gyimesi

Legendary Poster
Toni,
If you suppose that the spec is corrupted at the target location and it is an obstruction for the succes of the following attempts (Transfer/Check-In) then you can try to delete the object on the taget location using Delete in the Object Librarian before you attempt the transfer again.
I have never used this method, so I do not know that could it cause unwanted side-effects too.
Please, consider to use this method for your own risk.
On the other hand, let us know your results when you have tried it.
Good Luck!
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

Toni_Nanneman

Active Member
Thanks for the helpful information. I re-tried the transfer and check-in
again this morning before the masses signed on, and was able to successfully
compete both tasks. Nothing changed other than fewer users on the system.

So my question is this? How can I determine if my problem is related to
system performance (hardware) or software limitations (performing these
tasks while users are actively working)?

We have an NT deployment serving running SQL 6.5, running B7322 sp12.2 with
an AS/400 enterprise server which also servers our World A73 cum 8
application. We are planning to upgrade soon (Xe, Sql, World, et al) but
for now my question is this:

* Do others have standard operating procedures when you can/cannot
check in versions? Perform object transfers? Build workstation packages?




B7322 SP12.2; NT; SQL 6.5; coexist on AS/400 with A73 cum 8
 

got_to_love_jde

Reputable Poster
Re: RE: RDA Spec Problem

Toni,
Not sure you have identified the problem. I have a hard time believing activity caused your problem. There should be no limitations on check-in and out and transfers. I try to build my packages on the weekend but that doesn't mean my deployment server would not respond to users if i decided to do so during the week although they might get a delay.
I only do so to improve client response time.
dave

NT 4.0 SP5, SQL 7.0, One World B7321 SP12.4, Citrix 1.8 (XE soon)
 
Top