• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Primary key

erpteam

Member
Tables were created initially with 3 Primary keys.Business Views and forms were also created for the same.Thereafter the primary keys were changed and we generated the table(also index generated) and business views.
But while form interconnect we get the previous primary key though the table and business views are generated.

Please solve this issue as soon as possible

Thanks
ERP TEAM
 

Frosty the Coder

Legendary Poster
I'm guessing that these are all custom (tbls, bsvw, appls, ...).

Have you tried deleting FORM INTERCONNECT and re-adding it?

Also, system specifics (xe, 733, ...) could be helpful.

Gene



Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
 

Adrian_Chimirel

Legendary Poster
ERPTEAM,

A) Just a little confused by your ... '3 Primary keys' terms, allow me to cite some of JDE's Help Online:
"A table can have multiple indices; however, every table must have only one primary, unique index. The primary, unique index is the one unique identifier for each record in the table."
This being expressed, I'll be assuming you added a new index to your table(s). You don't need to generate the tables for that; index generation would have been sufficient :)

B) Now, I know it's discouraging, but do:
1. Replace old Form Interconnect with a brand new one; unfortunately, it is only its wizard that will allow you to select the (new) index.
That worked fine for my B7321 (and I'll make the dangerous assumption you are riding B7321, too; BTW, where is your system configuration? Please show it ASAP!).
If it doesn't, for you, a more drastic measure is to be taken:
2. Re-assign the Business Views to your forms and apply hint #1.
Evidently, you'll have to validate your APPL. DataStructure errors are very good indicators for the code to be 'refreshed', OR, UBE/Form Interconnect being the case, to be replaced.

Glossary: 'Refreshed code' means the Expression Manager (statement), or the System/Business Function call, or the If/While statement ... was open (dbl-clicked) & OK-ed.
Good luck and keep us informed about your success/or not :)

LIVE: B732.1 SP12.2, Oracle 806
SANDBOX: Xe SP15 & Update1, Oracle 8i
RS/6000, Citrix
 

Zoltan_Gyimesi

Legendary Poster
Just an addition to Andrian's answer.
To refresh an If/While statement in ER is a bit tricky.
When you open it then the OK button is not available, you have to make some dummy changes making OK available.
My practice is to re-select the If or While from the drop-down list in the very first column in the first row.
Regards,
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 
Top