• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Error: Delete an APPL object

Richard_Zhang

Active Member
Hi guys,

When I tried to delete one of my APPL programs, system pop out an error which said "Error: General Error in method, Delete" (Error ID:138F). This program has been checked in, and in a project which has a 21 status. I checked Activity rules, I couldn't see anything wrong. The rules are similar to UBE, I tried to delete a UBE object, no problem. Does anybody have any idea about this?

Thanks & regards,
Richard
 

Carl_Fisher

Well Known Member
Check User Overrides! I have seen a number of problems with applications in
OMW caused by User Overrides, if they exist for this Application.

By default OMW is not set up correctly for UO object type - look in the
Object Transfer Activity Rules, often UO is not included, or if it is the
location is wrong - should be Central Objects - PY7333 (for CRP/PY7333)
standard Xe comes with it set to Control Tables - CRP.

So for Status 21 to 21 you need an Object Transfer Rule:

User = *PUBLIC
Object Type = UO
From Location = Local
To Location = Central Objects - PY7333 (If you develop in CRP) or DV7333 (if
you Develop in DEV)
Allowed Action = 02 (Delete Only)

That should do it.

It may be worth checking the set up of UO object type in other Object
Transfer Rules. It is generally wrong!



OW733.3 Xe SP 14.2
Enterprise Server - Intel NT + Oracle 8.0.6
Client - Citrix TSE + 4 NT PC's for development
 

Richard_Zhang

Active Member
Re: RE: Error: Delete an APPL object

Hi Carl

Thank you very much! I tried your way, it works great!

Actually I saw some "can't delete user override " error from log, I thought that might be table security issue, I checked the Row security, there were not any security on it. I was never aware of there is UO type for Activity Rules.

One thing I wander why the local is Central Object ??7333 not System - 7333, is this location referring to SPEC files not F00950 table?

Thank you and have a nice day!

Regards,
Richard
 
Top