E1 9.2SP9.2 DS Windows 2012R2 STD: REGISTRY:Unable to find server (TextCtrlMod.dll)

Gopal_Kistasami

Active Member
Hi,

First time login to JDE on DS after successful installation of E1 9.2 Tools 9.2 on Microsoft Server 2012R2 Standard failed with message: Unable to update required components - Unable to register (TextCtrlMod.dll) Exiting !

The jde.log file contains:
1168/648 MAIN_THREAD Fri Mar 04 12:07:38.288000 jdb_ctl.c4196
Starting OneWorld

1168/648 MAIN_THREAD Fri Mar 04 12:08:19.384000 activConsole.cpp900
REGISTRY:Unable to find server (TextCtrlMod.dll) for unregistration

1168/648 MAIN_THREAD Fri Mar 04 12:08:20.446000 activConsole.cpp900
REGISTRY:Unable to find server (F:\JDEdwards\E920\system\bin32\TextCtrlMod.dll) for unregistration

1168/648 MAIN_THREAD Fri Mar 04 12:08:20.446001 activConsole.cpp834
REGISTRY:Unable to find server (F:\JDEdwards\E920\system\bin32\TextCtrlMod.dll) for registration

1168/648 MAIN_THREAD Fri Mar 04 12:08:20.446002 activConsole.cpp938
Unable to register (TextCtrlMod.dll) Exiting !

1168/648 MAIN_THREAD Fri Mar 04 12:11:17.874000 jdb_ctl.c6954
JDB4200001 - Failed to validate User handle

Please assist.
Many thanks,
Gopal
 

altquark

Legendary Poster
Gopal - did you install the deployment server "run as administrator". Are you launching the EnterpriseOne application "run as administrator" ?

Windows 2012 Server requires that you do both.
 

JDEE1Tips

Well Known Member
TextCtrlMod.dll issue is addressed in the below document, check whether it helps you !

E1: INST: Troubleshooting Login and After Installation Known Issues in a "Fat Client" (Doc ID 1149387.1) --> Scenario 3 - Client Installation Fails on Workstation with Registry Errors

Cause : This issue occurred because the DLLs were not registered.

Solution : On the machine that does not work, check the DLLs to make sure they are registered. These are located in the \system\bin32 directory:

You should be able to search the Windows registry to see if there are entries for the DLLs. Once you find them, the DLLs should have individual CLSID identifiers.

You can re-register DLLs whether you find entries for these or not. You can do so by opening a command prompt, going to the \system\bin32 directory and typing the following command:
regsvr32 xxxxx.dll

Where xxxxx is the name of the DLL file. Once the DLL files were registered, logging in to EnterpriseOne was successful.
 

Gopal_Kistasami

Active Member
Gopal - did you install the deployment server "run as administrator". Are you launching the EnterpriseOne application "run as administrator" ?

Windows 2012 Server requires that you do both.

Yes, as documented in the install manual. This bug has been in existence since 2003 from XE days. I am surprised that it still pops it's head.
 

Gopal_Kistasami

Active Member
Attempted registering the dll as per document Known Issues in a "Fat Client" (Doc ID 1149387.1) and I get failed to load check the binary or module could not be found. I have attached a word doc showing the RegSvr32 error.
 

Gopal_Kistasami

Active Member
I re-read the DS install chapter of the manual and found out that I missed the install of the 2010 VS executable - is required together with the MS VS 2013 Install. I downloaded the 2010 executable and installed on DS. I can now log into JDE 9.2 without any errors.
 

altquark

Legendary Poster
You're going to need VS Redistributable from 2005, 2008, 2010 and 2013 for all the pieces in an E1 implementation. I just push all of them (32bit and 64bit) to any of the windows machines that need them.
 

glen7x

Active Member
You're going to need VS Redistributable from 2005, 2008, 2010 and 2013 for all the pieces in an E1 implementation. I just push all of them (32bit and 64bit) to any of the windows machines that need them.

Jon is right. You are missing the VC Redistrubuitables. Get the 2013 32 & 64 bit ones and you would be good.
 
Top