• JDELIST is celebrating its 20 year anniversary today!
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Could not start/find web server - Standalone 9.2

Hi JDE Tech Gurus,
After thinking I have followed all the correct steps to install Standalone 9.2, I have got the thick client working but having trouble starting the web client. Running on Windows 7 Professional (dual boot with Win10). Details below.

Questions:
- Where are the web client logs?
- What steps can I take to troubleshoot the issue outlined below?

Install files:
32bit JDK: jdk-7u80-windows-i586
WebLogic: fmw_12.1.3.0.0_wls
32bit database client: V47124-01
E1LOCAL database and Client: V97804-01 / V97805-01 / V97806-01 / V100564-01

Installed using Oracle Support Install Guide, JDESource tutorial and much Googling.

Steps to reproduce error:
1. Start local client then Tools > EnterpriseOne Menu
2. Message: Starting Web Server
(several minutes wait time)
3. Error message: Could not start web server > press OK
4. Error message: Could not find web server > press OK
5. Error message: Failed to Launch E1 Menu on HTML Engine > press OK

I'm hoping for a specific sequence of log files to check to pinpoint the error. I have re-installed everything several times and feel/hope it is almost there without re-installing again.
Thanks, Randall.
 

JDEE1Tips

Well Known Member
Hi JDE Tech Gurus,
After thinking I have followed all the correct steps to install Standalone 9.2, I have got the thick client working but having trouble starting the web client. Running on Windows 7 Professional (dual boot with Win10). Details below.

Questions:
- Where are the web client logs?
- What steps can I take to troubleshoot the issue outlined below?

Install files:
32bit JDK: jdk-7u80-windows-i586
WebLogic: fmw_12.1.3.0.0_wls
32bit database client: V47124-01
E1LOCAL database and Client: V97804-01 / V97805-01 / V97806-01 / V100564-01

Installed using Oracle Support Install Guide, JDESource tutorial and much Googling.

Steps to reproduce error:
1. Start local client then Tools > EnterpriseOne Menu
2. Message: Starting Web Server
(several minutes wait time)
3. Error message: Could not start web server > press OK
4. Error message: Could not find web server > press OK
5. Error message: Failed to Launch E1 Menu on HTML Engine > press OK

I'm hoping for a specific sequence of log files to check to pinpoint the error. I have re-installed everything several times and feel/hope it is almost there without re-installing again.
Thanks, Randall.
Check the E1Server.log from the location C:\Oracle\Middleware\Oracle_Home\user_projects\domains\E1DevDomain\servers\E1Server\logs

Whether you have below line

3143733> <BEA-000357> <Started WebLogic Server independent Managed Server "E1Server" for domain "E1DevDomain" running in development mode.>
####<Jun 13, 2016 12:32:26 AM PDT> <Notice> <WebLogicServer> <E920DEMO> <E1Server> <[ACTIVE] ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1465803146296> <BEA-000360> <The server started in RUNNING mode.>
####<Jun 13, 2016 12:32:26 AM PDT> <Notice> <WebLogicServer> <E920DEMO> <E1Server> <[ACTIVE] ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1465803146421> <BEA-000365> <Server state changed to RUNNING.>


You can also refer our article for install the standalone 9.2 successfully !

JDEE1Tips : https://community.oracle.com/message/13858394#13858394

JDESource : http://www.jdesource.com/enterpriseone/jd-edwards-9-2-standalone-demo-installation-tutorial/
 
Last edited:
Check the E1Server.log from the location C:\Oracle\Middleware\Oracle_Home\user_projects\domains\E1DevDomain\servers\E1Server\logs
Thanks for your reply JDEE1TIPS, however I do not have that path in my Windows7 Standalone installation and a windows search across relevant directories did not find E1Server.log. From the directory structure and log filename, it sounds like that is related to a server install rather than the Standalone 9.1 installation I am troubleshooting.

Additional info: I enabled debug logging, restarted thick client, tried to start web client and found the following messages in the LOCALWEB_JDEDEBUG.LOG which seems to be directly related but additional googling has not yet found an answer.

Localweb debug log file is initialized
Jun 12 21:21:57.889 - 5432/2712 jdeStartAppServer check Activconsole
Jun 12 21:21:57.889 - 5432/2712 jdeStartAppServer check appServer
Jun 12 21:21:59.995 - 5432/2712 Http send request failed. Web application server may not be up
Jun 12 21:21:59.995 - 5432/2712 jdeStartAppServer start appServer
Jun 12 21:21:59.995 - 5432/2712 web application server is signaled to start.
Jun 12 22:29:12.268 - 5432/5948 Failed to open registry key for Internet Explorer. We are probably running Vista or higher Microsoft OS verion that does not have registry key for Internet Explorer
Jun 12 22:29:12.284 - 5432/5948 Trying to launch Internet Explorer with the Internet Explorer path set to iexplore.exe
Jun 12 22:29:14.376 - 5432/5948 Http send request failed. Web application server may not be up
Jun 12 22:29:14.376 - 5432/5948 web application server is signaled to start.

[the following line repeated many times]
Jun 12 22:30:17.736 - 5432/5948 Http send request failed. Web application server may not be up

Jun 12 22:35:23.003 - 5432/5948 Can not start Web Server. Check web error log for errors


Thanks for any further assistance.
Regards, Randall.
 

JDEE1Tips

Well Known Member
Thanks for your reply JDEE1TIPS, however I do not have that path in my Windows7 Standalone installation and a windows search across relevant directories did not find E1Server.log. From the directory structure and log filename, it sounds like that is related to a server install rather than the Standalone 9.1 installation I am troubleshooting.

Additional info: I enabled debug logging, restarted thick client, tried to start web client and found the following messages in the LOCALWEB_JDEDEBUG.LOG which seems to be directly related but additional googling has not yet found an answer.

Localweb debug log file is initialized
Jun 12 21:21:57.889 - 5432/2712 jdeStartAppServer check Activconsole
Jun 12 21:21:57.889 - 5432/2712 jdeStartAppServer check appServer
Jun 12 21:21:59.995 - 5432/2712 Http send request failed. Web application server may not be up
Jun 12 21:21:59.995 - 5432/2712 jdeStartAppServer start appServer
Jun 12 21:21:59.995 - 5432/2712 web application server is signaled to start.
Jun 12 22:29:12.268 - 5432/5948 Failed to open registry key for Internet Explorer. We are probably running Vista or higher Microsoft OS verion that does not have registry key for Internet Explorer
Jun 12 22:29:12.284 - 5432/5948 Trying to launch Internet Explorer with the Internet Explorer path set to iexplore.exe
Jun 12 22:29:14.376 - 5432/5948 Http send request failed. Web application server may not be up
Jun 12 22:29:14.376 - 5432/5948 web application server is signaled to start.

[the following line repeated many times]
Jun 12 22:30:17.736 - 5432/5948 Http send request failed. Web application server may not be up

Jun 12 22:35:23.003 - 5432/5948 Can not start Web Server. Check web error log for errors


Thanks for any further assistance.
Regards, Randall.
Check whether you have directory "C:\Oracle\Middleware\Oracle_Home\user_projects\domains\E1DevDomain" ? You should have this . if not then we need to check the install actions.log of your local web client
 
My Oracle_Home directory has the following sub-directories, but no "user_projects"

Directory of C:\Oracle\Middleware\Oracle_Home
11/06/2016 09:42 AM <DIR> coherence
11/06/2016 09:43 AM <DIR> install
11/06/2016 09:43 AM <DIR> inventory
11/06/2016 09:41 AM <DIR> OPatch
11/06/2016 09:43 AM <DIR> oracle_common
11/06/2016 09:43 AM <DIR> oui
11/06/2016 09:43 AM <DIR> wlserver


Located WLSH4A installActions log file and found reference to "Could not reserve enough space,SEVERE ERROR" and also "\Java\jdk1.7.0_80 was unexpected at this time"

Does this indicate what the problem is? ... Googling the error brings up references to 32bit vs 64bit Java. Which one do I need to install? How do I determine what I actually did install (JDK install file doesn't indicate 32/64).

Is there any other specific string I should search for within installActions log?

Thanks for your continued assistance and patience.

[LOG FILE SNIP]
filename = C:/Oracle/Middleware/Oracle_Home/user_projects/domains/E1DevDomain
INFO: Query Returned: false
INFO: Calling Action fileActions11.2.0.2.0 instantiateFileEx
source = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd
destination = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd.temp
variables = MWH
delimiter = ~
encoding = null

INFO: Calling Action fileActions11.2.0.2.0 removeFile
selectedNodes = null
source = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd

INFO: Calling Action fileActions11.2.0.2.0 moveFile
selectedNodes = null
source = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd.temp
destination = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd

INFO: Setting variable 'searchErrors' to ''. Received the value from a code block.
INFO: Setting variable 'searchErrors' to 'SEVERE ERROR:'. Received the value from a code block.
INFO: Setting variable 'searchErrors' to 'Could not reserve enough space,SEVERE ERROR:'. Received the value from a code block.
INFO: Calling Action e1GeneralActions11.0.0.0.0 SpawnWithReturnMsg
SpawnWithReturnMsg_installCommand = *Protected value, not to be logged*
SpawnWithReturnMsg_deinstallCommand = C:\E920_1\system\JAS\WLS_Scripts\deleteDomain.cmd
SpawnWithReturnMsg_searchErrors = Could not reserve enough space,SEVERE ERROR:
SpawnWithReturnMsg_waitFor = true

INFO: 06/11/16 14:17:49.823 >>>>> SpawnWithReturnMsg.installAction
INFO: 06/11/16 14:17:49.823 >>>>> SpawnWithReturnMsg.setSecure
INFO: 06/11/16 14:17:49.823 Secure: true
INFO: 06/11/16 14:17:49.823 <<<<< SpawnWithReturnMsg.setSecure
INFO: 06/11/16 14:17:49.823 >>>>> SpawnWithReturnMsg.doSpawn
INFO: 06/11/16 14:17:49.854 Start output from spawned process...
----------------------------------
INFO: 06/11/16 14:17:49.994 \Java\jdk1.7.0_80 was unexpected at this time.
INFO: 06/11/16 14:17:50.025 End output from spawned process.
----------------------------------
INFO: 06/11/16 14:17:50.041 <<<<< SpawnWithReturnMsg.doSpawn
INFO: 06/11/16 14:17:50.041 <<<<< SpawnWithReturnMsg.installAction
INFO: Calling Action fileActions11.2.0.2.0 instantiateFileEx
source = C:\E920_1\system\JAS\WLS_Scripts\deployE1.cmd
destination = C:\E920_1\system\JAS\WLS_Scripts\deployE1.cmd.temp
variables = MWH
delimiter = ~
encoding = null
[\LOG FILE SNIP]
 

JDEE1Tips

Well Known Member
My Oracle_Home directory has the following sub-directories, but no "user_projects"

Directory of C:\Oracle\Middleware\Oracle_Home
11/06/2016 09:42 AM <DIR> coherence
11/06/2016 09:43 AM <DIR> install
11/06/2016 09:43 AM <DIR> inventory
11/06/2016 09:41 AM <DIR> OPatch
11/06/2016 09:43 AM <DIR> oracle_common
11/06/2016 09:43 AM <DIR> oui
11/06/2016 09:43 AM <DIR> wlserver


Located WLSH4A installActions log file and found reference to "Could not reserve enough space,SEVERE ERROR" and also "\Java\jdk1.7.0_80 was unexpected at this time"

Does this indicate what the problem is? ... Googling the error brings up references to 32bit vs 64bit Java. Which one do I need to install? How do I determine what I actually did install (JDK install file doesn't indicate 32/64).

Is there any other specific string I should search for within installActions log?

Thanks for your continued assistance and patience.

[LOG FILE SNIP]
filename = C:/Oracle/Middleware/Oracle_Home/user_projects/domains/E1DevDomain
INFO: Query Returned: false
INFO: Calling Action fileActions11.2.0.2.0 instantiateFileEx
source = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd
destination = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd.temp
variables = MWH
delimiter = ~
encoding = null

INFO: Calling Action fileActions11.2.0.2.0 removeFile
selectedNodes = null
source = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd

INFO: Calling Action fileActions11.2.0.2.0 moveFile
selectedNodes = null
source = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd.temp
destination = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd

INFO: Setting variable 'searchErrors' to ''. Received the value from a code block.
INFO: Setting variable 'searchErrors' to 'SEVERE ERROR:'. Received the value from a code block.
INFO: Setting variable 'searchErrors' to 'Could not reserve enough space,SEVERE ERROR:'. Received the value from a code block.
INFO: Calling Action e1GeneralActions11.0.0.0.0 SpawnWithReturnMsg
SpawnWithReturnMsg_installCommand = *Protected value, not to be logged*
SpawnWithReturnMsg_deinstallCommand = C:\E920_1\system\JAS\WLS_Scripts\deleteDomain.cmd
SpawnWithReturnMsg_searchErrors = Could not reserve enough space,SEVERE ERROR:
SpawnWithReturnMsg_waitFor = true

INFO: 06/11/16 14:17:49.823 >>>>> SpawnWithReturnMsg.installAction
INFO: 06/11/16 14:17:49.823 >>>>> SpawnWithReturnMsg.setSecure
INFO: 06/11/16 14:17:49.823 Secure: true
INFO: 06/11/16 14:17:49.823 <<<<< SpawnWithReturnMsg.setSecure
INFO: 06/11/16 14:17:49.823 >>>>> SpawnWithReturnMsg.doSpawn
INFO: 06/11/16 14:17:49.854 Start output from spawned process...
----------------------------------
INFO: 06/11/16 14:17:49.994 \Java\jdk1.7.0_80 was unexpected at this time.
INFO: 06/11/16 14:17:50.025 End output from spawned process.
----------------------------------
INFO: 06/11/16 14:17:50.041 <<<<< SpawnWithReturnMsg.doSpawn
INFO: 06/11/16 14:17:50.041 <<<<< SpawnWithReturnMsg.installAction
INFO: Calling Action fileActions11.2.0.2.0 instantiateFileEx
source = C:\E920_1\system\JAS\WLS_Scripts\deployE1.cmd
destination = C:\E920_1\system\JAS\WLS_Scripts\deployE1.cmd.temp
variables = MWH
delimiter = ~
encoding = null
[\LOG FILE SNIP]
See here

destination = C:\E920_1\system\JAS\WLS_Scripts\createDomain.cmd

INFO: Setting variable 'searchErrors' to ''. Received the value from a code block.
INFO: Setting variable 'searchErrors' to 'SEVERE ERROR:'. Received the value from a code block.
INFO: Setting variable 'searchErrors' to 'Could not reserve enough space,SEVERE ERROR:'. Received the value from a code block.

OUI Installer tried creating the Domain ( E1devDomian ) under user_projects but failed to create the domain because of the space issue , So OUI Installer didn't configure the Local Web client for you !

As a result of this , when you are tying to launch the EnterpriseOne Menu , JD Edwards EnterpriseOne is not be able to locate the Web Server . This leads to the error message unable to Locate the Web Server.

If we resolve the issue, you will be able to install and configure the Standalone 9.2 Local web client for sure !!!

Lets us know how much Space you have in C Drive ? Then we can will look into Java issue
 
Last edited:
Lets us know how much Space you have in C Drive ? Then we can will look into Java issue
There is 102GB free space on the C Drive, so I don't think that would be the issue.

I confirmed the JDK is 32bit after reviewing the Oracle Support install guide steps and looking into the Control Panel / Programs and Features.

Happy to be making progress... what's next?
 
See here
If we resolve the issue, you will be able to install and configure the Standalone 9.2 Local web client for sure !!!

Lets us know how much Space you have in C Drive ? Then we can will look into Java issue
Thanks for your assistance JDEE1Tips... are you able to provide further advice to resolve this issue?
As I mentioned, there is 102GB free space on the C-drive.

Thanks in advance.
Randall.
 

JDEE1Tips

Well Known Member
Thanks for your assistance JDEE1Tips... are you able to provide further advice to resolve this issue?
As I mentioned, there is 102GB free space on the C-drive.

Thanks in advance.
Randall.

Hi Randall,

Do you have JDeveloper installed in the same machine ?

We have a experience if JDeveloper is Installed, we will face the exact same error message.

INFO: Setting variable 'searchErrors' to 'SEVERE ERROR:'. Received the value from a code block.

If yes we will provide the solution for this case.
INFO: Setting variable 'searchErrors' to 'Could not reserve enough space,SEVERE ERROR:'. Received the value from a code block
 

JDEE1Tips

Well Known Member
Hi, thanks for your continued assistance. No, I don't have JDeveloper installed. I have never installed/used JDeveloper.

Regards, Randall.
Send us the complete install actions<timestamp>.log for Standalone 9.2 in mail (info@JDEE1Tips.com) , Lets compare and try to find out what is going wrong

Location : C:\Program Files (x86)\Oracle\Inventory\logs
 
Last edited:

JDEE1Tips

Well Known Member
Log files sent. Thanks.
Issue is not because of Space. Because even in successful Standalone 9.2 Installation we have the same error message

SpawnWithReturnMsg_searchErrors = Could not reserve enough space,SEVERE ERROR:
SpawnWithReturnMsg_waitFor = true

We need to focus on the error message

INFO: 06/11/16 14:17:49.994 \Java\jdk1.7.0_80 was unexpected at this time

Where you Installed the 32bitJava ? Is it under C:\Program Files (x86)\Java Folder ?

Standalone Local Web issue.jpg
 
Where you Installed the 32bitJava ? Is it under C:\Program Files (x86)\Java Folder ?
Hi,
Yes, Java *was* installed within (x86)\Java.

This gave me insight into the problem, where I searched on the Java error and found an Oracle article referencing the issue. The problem is with running WebLogic on Win7 64bit when Java is installed in a path which contains brackets.

I did a complete re-install, starting with Java installed directly to C:\Java and after solving a couple of minor problems... it works!

Thank you!!

Regards, Randall.
 

JDEE1Tips

Well Known Member
Hi,
Yes, Java *was* installed within (x86)\Java.

This gave me insight into the problem, where I searched on the Java error and found an Oracle article referencing the issue. The problem is with running WebLogic on Win7 64bit when Java is installed in a path which contains brackets.

I did a complete re-install, starting with Java installed directly to C:\Java and after solving a couple of minor problems... it works!

Thank you!!

Regards, Randall.
Glad to hear form you !
 
Top