AS400 - jobs abended, no joblogs, nothing in DSPLOG.....

Frosty the Coder

Legendary Poster
Our nightlyjobs are submitted from a OW menu, to 3 diff HELD jobqs on our
400.
(This is to get around issues w/SCHEDULER, RUNUBE, .....)

This procedure has been working for many months, w/out any problems.

Fri night, the jobs kicked off as scheduled, after the completion of
backups.

The 1st nine jobs that had been submitted died.
The next six ran to completion.
The next five died.
The next 23 ran to completion.
The next 6 die.
The final 14 ran to completion.

The completions and abends are found in each of the jobq's.

The completions and abends are comprised of JDE vanilla
and custom batch jobs.

The completions and abends are such that one version of
a job (ie r42520 (pick slip print)) fails and it is immediately
followed by a diff version of that same job, which completes
(in the same jobq).

We have resubmitted _some_ of the failed jobs, this morning,
and they've run to completion.

WSJ just says the jobs ERRORED. We cannot view the logs,
as we don't run w/logging turned on. Performance is bad enough
as it.

There are no joblogs on the 400 that might give a clue as to what
may have happened.

DSPLOG for the time span that these just shows the jobs starting
and completing w/out mentioning the fact that they did abend. Nor
do we see any other jobs/events that would cause this to occur.

This being the case, where can we look to find out what happened?

TIA for any/all help, suggestions.

Gene

PS - there is a great email floating about of WINDOWS err msgs written
as Haiku. Paraphrasing one to express THIS situation:

Yesterday it worked.
Today it is not working.
Oneworld is like that.



Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
 
Gene,

You are definitely not alone. We have that happen regularly. Many times for
no reason batch applications quit working. Usually all we need to do is
check the version in and out and that fixes it.

Some applications end in error, but they seem to have worked. Usually,
there is this error message:

Sun Apr 29 21:56:37 2001 JDEKRNL_O/C/JDB_UTL13491
JDB9900359 - Failed to validate action for un-initialized lock 3

I think I'll have that Haiku placed in a frame and hung over the AS/400.

Tom Chmielewski
Sr. Programmer/Analyst
Flair Corp.
Ocala, Fl
B7332, SP11.3
AS/400 V4R4
NT 4.0 Citrix



Tom Chmielewski
Sr. Programmer/Analyst
Flair Corp.
Ocala, Fl
 

Jack_Crouch

Well Known Member
This is almost always due to versions being changed. If a user checks
out, then checks in (even if they do not change anything)... Then your jobs
running on AS/400 will not like those specs.

Submit version specs to server (under Advanced) and I bet they run tonight.




AS400 V4R4, B733.2, SP11.3, NT-SQL7 for CO
 

Frosty the Coder

Legendary Poster
I wish it were due to versions having been changed.
I know that, in this case, it is not so. The versions are static.

I'm just frustrated that, with gobs of 400 and World experience,
I'm unable to say "here's what happened".

More importantly, I'm frustrated in being unable to say
"it won't happen again".

Gene



Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
 

Frosty the Coder

Legendary Poster
Jorge

I'm not the guy who runs the ops, but I will check w/them.

If this were the issue, I'd think that we should have hit it prior to now.

Further, last night everything ran without any problems.

When your jobs abend, is it ALL the jobq'd jobs or
just some of them? If the latter, do they fail/work/fail/work....?

Whatever it was, it seems to have been a one-time event,
(encountered 3 times during the night).

My complaint is that we have no way of finding what it was
to prevent it from happening again.

Thanks

Gene

PS - cool email addr.....



Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
 
Top