• Welcome to the upgraded JDELIST forum and thank you for your patience.
    Please restrict discussions and issues regarding the new forum software to the Off Topic forum. We will be monitoring that forum for issues.
    If you have trouble logging in, please reset your password using the forgotten password form: https://www.jdelist.com/community/index.php?lost-password/
    If you are unable to successfully reset your password, please contact us: Click here!
    We hope that you enjoy the upgraded forum.
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

AIS Appstack subsequent requests receiving error "invalid rid"

teckhoff

Member
Hello,

I am following this documentation for creating multiple form requests to the appstack endpoint: https://docs.oracle.com/cd/E53430_01/EOTRS/op-appstack-post.html

The first request to open the connection is successful. For my second request, I am using the stateId, stackId and rid that is returned in the response from the first request as the documentation says to do. However it is returning the following error, implying the rid value is invalid:

{"sysErrors":[{"TITLE":"Did not connect to correct Session (invalid rid)","DESC":"Did not connect to correct Session (invalid rid)"}]}

I'm copying/pasting it exactly from the first request's response data, so no idea how it could be invalid. Anyone encountered this error?

Thanks!
 

MrsRansom

Member
We ran into an issue like this which was caused by us not sending the correct stack ID, state ID, and RID together. So for example we had the correct RID, but we were sending in a non incremented state ID. Another issue that we had run into was not putting quotes around the RID.
 
Top