E9.2 [9.2.4.3] COK Zombies, Cleanup.exe crash

MacaqueJDE

Active Member
Hey everyone!

We are having a problem for a week here with JDE, and we can't find a solution.

We get OCK zombies non-stop, like 150-200 a day. Doesn't seem to impact production much, but I think it makes everything slower.

Now after looking everywhere, we found something :

The cleanup.exe crash when starting the entreprise server.

Faulting application name: cleanup.exe, version: 0.0.0.0, time stamp: 0x5e6fae24
Faulting module name: jdekrnl.dll, version: 1.0.0.1, time stamp: 0x5e6fad58
Exception code: 0xc0000005
Fault offset: 0x000cbf1f
Faulting process id: 0x1424
Faulting application start time: 0x01d71ff6f52c61f3
Faulting application path: D:\JDEdwardsPPack\E910\system\bin32\cleanup.exe
Faulting module path: D:\JDEdwardsPPack\E910\system\bin32\jdekrnl.dll
Report Id: 7c3cba2f-289c-4a9f-8160-18bffe7df012
Faulting package full name:
Faulting package-relative application ID:

I have no idea why, and I can't find any info about this.

cleanup.exe hasn't been changed since we created the server (3 month ago).

Each time a process is call, the cleanup function seems to crash and it get stuck during jdbcache clean up phase at the end.

Anyone ever got a similar issue?
 

Tom_Davidson

VIP Member
I don't run services on windows, but I'd try cleaning up DDDICT, DDTEXT, GLBLTBLS, and the /<pathcode>/specfile/runtimecache and /<patcode>/specfile/UBEOverride directories.

This seems to solve a multitude of issues on occasion.

Also, depending on how busy your system is, I normally don't have to down to clean this stuff up, just make sure that the UBE/Version or process ID is in use when you wack them. I normally don't have an issue on the DDDICT, DDTEXT, andGLBLTBLS

Tom
 

MacaqueJDE

Active Member
Yeah we tried to delete every cache, and still no luck :(

We went with the atomic bomb solution : We restored a backup of the entreprise server taken before the issue.

It worked.

We are pretty sure it was some kind of file corruption that occured, but we will never know.

Thanks!
 

Larry_Jones

Legendary Poster
If I were you I'd do some full package builds (starting in Dev), make sure they work in Dev/CRP, the Build/Deploy in PROD.
I thinked you had corrupted specs, and right now you may be out of synch.
 
Top