• Welcome to the upgraded JDELIST forum and thank you for your patience.
    Please restrict discussions and issues regarding the new forum software to the Off Topic forum. We will be monitoring that forum for issues.
    If you have trouble logging in, please reset your password using the forgotten password form: https://www.jdelist.com/community/index.php?lost-password/
    If you are unable to successfully reset your password, please contact us: Click here!
    We hope that you enjoy the upgraded forum.
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Print Immediate and OSA

Hi

We have recently setup JDE to use OSA for use with Transfom (the new formscape), it is all working well but we have one outstanding problem. When a user submits a report using OSA, they have to untick the 'Print Immediate' flag. If they don't, they get the JDE print and the Transform print.
Its not a major problem, but users will complain.
Is there any way to set a report to never use print immediate?

Regards
Jamie
 

jileto

Member
I believe it has been mentioned before...

You should use a NULL printer as a default printer for all users, all environments, all UBEs/Versions. This will give you the flexibility of defining which user/environment/ube/version combination will use a Formscape queue using the Default Printers functionality of JDE. Direct output to the NULL printer if you don't want Formscape to do anything.

Combined with the JDE's OSA Interface setup function (which defines when OSA output is generated), you can set up combinations like:
- UserA using UBEA/Version1 in any environment will only generate OSA output.
- UserB using UBEA/Version1 in PD environment will generate only a PDF output - no Transform output if the default printer is set to a NULL printer.
- Group1 users using UBEA/any version in any environment will generate a Transform output - PDF output sent to a Transform queue
- etc., etc.

A NULL printer is like a black hole, it just gets a print job but does not send it anywhere. You can do a web search to locate web pages that describe how to create one.
 

svenh

Member
Hi
If you know the involved report versions, you could use the option "suppress all output". This option will suppress the PDF Output but will not suppress the OSA Output.
Regards,
Sven
 

srossi27

Member
Ignore my last update, I found it, within the Report Design Aid (RDA) under the Report Properties, located from the pull down menu for Report and then Report Properties, select the option for Suppress All Output.

Cheers
 
Top