R09801 not posting in server


Well Known Member
We created a new index in F0411 table and after we made an update package with this table and deployed it to the server, my R09801 UBE started not posting the status of the accounting ledger. I've already deleted the global tables on the server, made a new update package including R09801 but nothing solved my problem. If I run it locally it works fine. The log of the execution is above and it seems to complain about a trigger to the table that we've created in the past and it used to work, if anyone can help me i'll be very grateful.
(Someone told me to make a new server package and I made it and I'll deploy it to the server tomorrow morning. Deploying this full server package has some risk to my instalation?)

Thank You

710 Fri Sep 1 15:48:58 2006 runbatch.c382

710 Fri Sep 1 15:48:58 2006 ipcpub.c3121
process 710 <B7334SYS/PRINTUBE> registered in entry 24

710 Fri Sep 1 15:48:59 2006 runbatch.c632
Startup for User=LEONICE, Env=PD7333, Job#=3763238

710 Fri Sep 1 15:49:11 2006 runbatch.c1124
RUNBATCH: Remote CP=1252, Remote OS=5, Local CP=37, ConvertToASCII=0

710 Fri Sep 1 15:49:55 2006 jdeobj.c1181
COB0000008 - Could not retrieve BLC Header.

710 Fri Sep 1 15:49:55 2006 jdb_exet.c2089
JDB3600009 - Failed to update PRE Trigger - F0411

710 Fri Sep 1 15:50:44 2006 ipcpub.c3432
API ipcSawUnregisterProcV1 : process 710 unregistered in entry 24

710 Fri Sep 1 15:50:44 2006 jdb_ctl.c4519
Are talking about deleting SQL Packages? I've deleted SQL packages every day and I still have this problem.
After you added the new index did you run generate indexes on the Table Operations tab in OMW Design?

I assume F0411 was in your update package. When a package is built that calls BusBuild and F0411 will, a temporary folder called BusObj is created in the pathcode where you run the build from. This folder is not deleted after the build. I remember many years ago this cause a server package problem on subsequent builds. I make a habit of always deleting this folder before the next build. This idea is totally a shot in the dark but I thought I would pass it along. You also might try turning on logging when you submit the batch (R09801)to the server, it will give you more detailed information to help you troubleshoot the issue. You will find this in the jdedebug.log file on the server.