• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Pristine pkg build

jdehowto

Member
Good Morning!

we are having a situation where custom objects are being referred to in Pristine Package build. It lists all custom objects in buildlog.txt and mentions it as "object not checked into path code, excluded from the build"

The above to me is not an issue but somethign we discovered while troubleshooting another thing. And that is a list of standard objects are failing (unable to copy from CheckIn to pkg\source folder); this is happening in all pathcodes including Pristine (error message: "Thu Apr 16 07:43:01 - spkgclnt.c:709 PKGCLT0030 ERROR: Failed to add file name to message. Error File open error.Thu Apr 16 07:43:01 - spkgclnt.c:1437 PKGCLT0054 ERROR: Failed to transfer \\DEPSVR\E910\PS910\package\PS910FC\source\n7000070.c to the server.")

Any idea what common thing is messed up here !! ??




Thanks,
 

JEMILLER

VIP Member
The custom objects in the Pristine build is an expected behavior. The package build is driven by the F9860 (OL Header) when selecting BSFNs for compile. A join to the F9861 (OL Detail) based on the package path code is not done. This may have been fixed in newer tools releases but it has been happening so long I don't pay attention anymore.
 

jdehowto

Member
The custom objects in the Pristine build is an expected behavior. The package build is driven by the F9860 (OL Header) when selecting BSFNs for compile. A join to the F9861 (OL Detail) based on the package path code is not done. This may have been fixed in newer tools releases but it has been happening so long I don't pay attention anymore.

Hi Miller!
My system is on 9.1/9.1.4.7

The reason as to why i observed this is that we are facing failure of many objects in all path codes including PS910.
Fortunately we were able to trace the issue to wrong entries in F9862 for EventKey for the failed NERs. The keys in F9862 were not matching those in F98741. Restore of F9862 fixed this. However "since i observed custom objects first time ever in PS" i reported this. And this is called object-corruption as per Oracle KG Doc. E1: ESU: Troubleshooting "Enable or Disable Enhancements" UBE R96450 During a Software Update Install ( Doc ID 1323124.1 ) . Not sure how corrupt entries would creep in to my P9862 or F98741.


Thanks for your response anyways.





Thanks,
 
Top