Excel doesn't split cells automatically opening CSV file

Zoltan_Gyimesi

Legendary Poster
Excel doesn\'t split cells automatically opening CSV file

Hi JDEList!

I have created CSV output from OneWorld following the instructions of ott-00-0047 documentation.

The file correctly created but opening the CSV file with Excel, loads the entire row into Column A instead of splitting the row into cells at the commas. So, I have to split Column A into several field manually using the Data / Text To Columns... Excel function. It's OK for me but is not for the end user.

I didn't find any setting in Excel to set up the splitting automatically when I open CSV file.

Any help, hint, guideline will be greatly appreciated.

Regards,

Zoltán
 

Randy

Active Member
RE: Excel doesn\'t split cells automatically opening CSV file

What type of report are you using, Columnar, Group, Tabular????????


Thank You,
Randy Epps
Senior JDE Developer
One Source Consulting
(214) 538-6759
www.1sourceconsulting.com
 

DSauve

Legendary Poster
Re: Excel doesn\'t split cells automatically opening CSV file

Greetings, Zoltan!

It's always nice to see your posts on the list.

If possible, could you post a copy of the csv file being generated on this forum so we could look at it and/or try to import it? What version of Excel are you using for opening the csv file? Also, do you use the comma as a decimal separator?
 

Zoltan_Gyimesi

Legendary Poster
Re: Excel doesn\'t split cells automatically opening CSV file

Hi Don,

First of all thanks for your welcome and fast response!

I am currently just making experiments with CSV to prepare for a task in the near future. So, my CSV contains "ad hoc" or dummy data.

Please, see the CSV file in the attachment!

The version of my Excel is:

Microsoft Excel 2000. (Version 9.0. Build: 2720)

In the attached CSV I used dot as decimal separator instead of comma.
(of course, I made experiments with various settings;-)

An other observation: I placed a column into the UBE section /Desription/ which contains commas inside the field. The CSV kept the field in one cell removing the commas from the field.

Regards,

Zoltán
 

Attachments

  • 57935-R59GZ004_ZGYZ001_D1030710_T162718601.zip
    7.6 KB · Views: 123

DSauve

Legendary Poster
Re: Excel doesn\'t split cells automatically opening CSV file

Hi Zoltan,

We're also running Microsoft Excel 2000 (version 9.0.6926 SP-3). I was able to open your .csv file just fine in Excel. I saved the file as a .xls file, which I'm attaching to this post. I looked in Excel for some settings about opening CSV files and converting fields, but didn't find anything.

Have you tried to open the csv file on another PC? Maybe something's gotten messed up on the PC on which you have been trying to open the csv file. That's about all I can think of for now.
 

Attachments

  • 57939-R59GZ004_ZGYZ001_D1030710_T162718601.xls
    92.5 KB · Views: 184

Zoltan_Gyimesi

Legendary Poster
Re: Excel doesn\'t split cells automatically opening CSV file

Hi Don,

Of course, we tried to open the CSV file on three other machine too.
Unfortunately with the same result :(

Thanks for your cooperation!

Zoltán
 

Zoltan_Gyimesi

Legendary Poster
Re: Excel doesn\'t split cells automatically opening CSV file

Hi Don,

It seems so that I found the solution.

In the Regional settings I changed the List Separator from our semicolon to comma, it worked fine.

Would you please check, what is your List Separator in the Regional settings.

What hapens when you change this separator to semicolon and reopen the CSV?

Thnaks again your cooperation!

Zoltán
P.S.: maybe I can read your answer only on next Tuesday.
 

Adrian_Chimirel

Legendary Poster
Re: Excel doesn\'t split cells automatically opening CSV file

Servus Zoltán,
Attached is my Reg Settings, for the moment.
Warm regards,
 

Attachments

  • 57959-Reg Settings.zip
    63.2 KB · Views: 138

DSauve

Legendary Poster
Re: Excel doesn\'t split cells automatically opening CSV file

Zoltan,

My Regional Setting for the list separator was ",". I changed it to ";" and then the .csv file wouldn't parse properly in Excel. I changed it back to "," and then the .csv file opened up just fine. So looks like you hit the name right on the head! Thanks for the follow-up.
 

jackng

Member
Re: Excel doesn\'t split cells automatically opening CSV file

For our JAS users, they have to do this to read a csv file.

1. Download the file to the PC
2. Open Excel
3. In Excel, open the csv file. There will be a wizard pop up on the screen.
4. You can then check the comma separated option on the pop up box and the file should display correctly.

Let me know if that helps.

Thanks.

Jack
 
Top