• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Error on RUNUBE

ka4niv

Active Member
Greetings All ...

First time to try the /400 RUNUBE command results thus:

Signal SIGABRT raised (abnormal termination).
Application error. C2M1601 unmonitored by QC2UTIL1 at statement
0000000005, instruction X'0000'.
Function check. CEE9901 unmonitored by RUNUBETEST at statement 300,
instruction X'0010'.
CEE9901 received by RUNUBETEST at 300. (C D I R)

Anyone ever seen such?
What does it mean?
What do I do now?

Many thanks ...

Maurice
Xe SP14 ES - AS/400 CO - AS/400 Deploy - NT Citrix
 

wojcik

Active Member
We've found that by moving up to SP15.1 it seems to have soved all our issues with RUNUBE. We were told that we needed to do this to solve some of our RUNUBE problems.

However, you might want to try some of the following as well...

1. I assume the UBE runs when you run it on the enterprise server. If not, this must be solved first.

2. Do you have an entry at all in Work Serevr Jobs. If present, have a look at the PDF, it may show something.

3. Try starting debug (STRDBG) with no program but setting update prod files = *YES. Then run the RUNUBE from t a command line. Examing the job logs may then show something...


AS/400 V4R5, B733.2 and XE
 

dschlieder

Well Known Member
Maurice,

Had this same error last night!

In my case, I had the name of the UBE wrong in the RUNUBE command.

I had a "0" zero for the letter "O" in the name of the UBE....

Another possiblilty is that the UBE is not installed on the server which might be the case with a new UBE or a new version that has never been installed.

Dave
 

ka4niv

Active Member
Thanks for the quick response ...

files

returns:
runube: JDB_InitEnvOvr failed with rcode = 0
Press ENTER to end terminal session.
Job Log shows:
Signal SIGABRT raised (abnormal termination)

Tweaked the environment parameter in the RUNUBE, no affect.
Changed the user-id and password to be a different user, and it is still
running.
Go figure.

Thanks again.
Maurice

Xe SP14 -- ES:AS/400 -- CO:AS/400 -- Deploy:NT -- Citrix
 

Toni_Nanneman

Active Member
I had this very problem. It is a known problem with the RUNUBE command and
is supposed to be fixed in SP16. I was given a Breaking News document,
OTI-01-0048, which gives you a work around for making this work. Here's the
basic info from that document...

The issue:
The problem is that when running the RUNUBE command from the command line
with multiple UBEs in succession, OneWorld creates a SQLPKG named OWPKG.
OWPKG occasionally becomes corrupt in the above scenarios. So far, this
issue has only been seen with the installation of SP15.

The workaround...
Delete the OWPKG SQLPKG that get created in the syslib (e.g B7333SYS). If
you are submitting UBEs through scheduler in a jobqueue with other UBEs, you
will need to set up a CL program to delete the OWPKG SQLPKG after each UBE
has run.

Pending resolution:
Development is preparing a fix that should force all UBEs run through RUNUBE
to create their own SQLPKG instead of re-using the OWPKG SQLPKG . The SAR
for this fix is 5094624 and will be corrected in SP16.

Toni Nanneman



B7322 SP12.2; NT; SQL 6.5; coexist on AS/400 with A73 cum 8
 
Top