NETWORK and JDENET_K die: MCH3402 unmonitored by QC2UTIL1 error

Crazy_About_JDE

Well Known Member
Hello, list! Before I post my Wednesday challenge, I must say you have all been a priceless asset during the process of upgrading OneWorld Xe to E1 8.0 (yes that's 8.0) and changing to a new enterprise server and a new deployment server. THANK YOU! And now...another head-scratcher:

We've been running and testing EnterpriseOne 8.0 Update 1 SP 23 on a new IBM iSeries server, OS/400 V5R3, for more than two months. Now that we've ironed out all the wrinkles, everything that we've tested is blazing fast and error-free. We are scheduled to go live Saturday. Then reality hit when, just two days ago, we found the NETWORK job ended "abnormally" in the middle of the day for no apparent reason. I hoped it was a fluke or that "someone" ended the services accidentally...but then it happened again yesterday.

We can get back up with ENDNET, CLRIPC, and STRNET -- but it will obviously be disruptive if it continues to happen when we're in production.

I scanned the system log and found, in both cases, that R42800 (Sales Update) had been running (manually submitted for testing) at the time the NETWORK job and JDENET_K jobs ended. The first time it happened around 11:04 AM, the second time around 10:35 AM. Thinking Sales Update was the problem, we tested every version of R42800 but could not crash the kernels.

In both cases, when we discovered the jobs had ended, we saw that SENTINEL was still running in the B7334SYS subsystem.

Here is a clip from NETWORK's QPJOBLOG that looks relevant. Other logs are attached. Does anyone have any idea what might be happening?

MCH3402 Escape 40 06/13/06 10:35:52.780560 QmDeqMiQueue 0002D0 <font color="blue">JDEIPC B7334SYS</font> *STMT

To module . . . . . . . . . : MSG
To procedure . . . . . . . : JDE_msgrcv
Statement . . . . . . . . . : 7 *PRCLT
Message . . . . : <font color="blue">Tried to refer to all or part of an object that no longer exists.</font>
Cause . . . . . : The most common cause is that a stored address to an object is no longer correct because that object was deleted or part of the object was deleted.

CEE9901 Escape 30 06/13/06 10:35:53.145752 QLEAWI QSYS *STMT QCMD QSYS 01B7
From module . . . . . . . . : QLEDEH
From procedure . . . . . . : Q LE leDefaultEh
Statement . . . . . . . . . : 168

Message . . . . : <font color="blue">Application error. MCH3402 unmonitored by QC2UTIL1 at statement 0000000003, instruction X'0000'.</font>
Cause . . . . . : The application ended abnormally because an exception occurred and was not handled. The name of the program to which the unhandled exception is sent is QC2UTIL1 QC2MI3 deqi. The program was stopped at the high-level language statement number(s) 0000000003 at the time the message was sent. If more than one statement number is shown, the program is an optimized ILE program. Optimization does not allow a single statement number to be determined. If *N is shown as a value, it means the real value was not available.
Recovery . . . : See the low level messages previously listed to locate the cause of the exception. Correct any errors, and then try the request again.
 

Attachments

  • 108236-MCH3402unmonitoredbyQC2UTIL1.zip
    22.5 KB · Views: 103

jstooge

VIP Member
A few suggestions. I didn't see the actual job log from the UBE itself, but that log would probably be very useful. I'm sure you've done it, but I'd bring down services and delete the SQLPKG's. Also, might not be a bad idea to refresh the indexes on any tables the UBE is hitting. IBM has issued 2 E1 APAR's in about the last month, there is a very recent one, I'd apply that to the system as you know if you call for assistance, that's the first thing you'll get hit up on. Do you see this with ANY running of that UBE? If not, can the parameters of the runs that crash be investigated and compared to runs that don't?

In addition to the above, I'd get IBM on your system right away, they can use SST's to look at the low level stuff and usually can quickly determine if it's a OS/400 issue or something they think Oracle needs to assist with.

As Astro would say...Rotsa ruck Relroy.
 

Ian Simmons

Member
Hi there, I know this is 6 years ago (!), but we have just experienced this very issue. I am just hoping that you are sill working for the same organisation and may retain some memory of this issue! We are still on Xe, on V5R4 - yes, I know - but it is stable, generally. On Friday (June 29th) this very thing happened to us, a lonely Sentinel job was left running in production, all the network and kernel jobs had ended, and this exact message appeared in one of the first job logs ('Tried to refer to all or part of an object that no longer exists.'). Did you ever get to the bottom of this?

Many thanks
Ian
 
Top