BusinessServiceException error while calling BSFN directlly from BSSV

kishorgite

Member
I am calling BSFN B0404110 directly via BSSV .
If we call this BSFN via report(UBE) it is working fine but we need to call it from BSSV .

We are facing below error :

oracle.e1.bssvfoundation.exception.BusinessServiceException:

CAUSE . . . . The record to be fetched from table F0011 does not exist or you
do not have authority to fetch records from this table.
RESOLUTION. . Verify that the record being fetched exists and that you have
proper authority. Check the JDE.LOG and JDEDEBUG.LOG for
additional information.

We are passing below inputs :

internalVO.setSzReport("1");
internalVO.setCSynch("Y");
internalVO.setSzJobQueue("104280");
internalVO.setSzVersionJDE("IPM0003");
internalVO.setSzDataSourceOverride(" ");
// "IPM0003"
// map input parameters from input value object
// map input parameters from input value object
// map input parameters from input value object
bsfnParams.setValue("cProofFinalFlag", internalVO.getSzReport());
bsfnParams.setValue("cOutofBalFlag", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("cPurgeFlag", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("cSupressWarningFlag", internalVO.getSzReport());
bsfnParams.setValue("szUserId", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("cBtpassTaxDefault", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("VoucherEntryVersion", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("JEVersion", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("BatchApproval", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("PostVer",internalVO.getSzDataSourceOverride());
// bsfnParams.setValue("idGenericLong", internalVO.getIdGenericLong());
bsfnParams.setValue("szEdiUserId", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("szEdiBatchNumber", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("szEdiTransactNumber", internalVO.getSzJobQueue());
bsfnParams.setValue("cMCICFlag", internalVO.getCSynch());

internalVO.setSzDataSourceOverride(" ");
bsfnParams.setValue("szCountryCode", internalVO.getSzDataSourceOverride());
bsfnParams.setValue("szReportVersion",internalVO.getSzVersionJDE());

Thanks in advance .
Regards
Kishor
 

Lucky.2811

Active Member
How are you testing , local or in server. If server what is the web sever. Is it OAS, Websphere or Web logic?

Issue might be with secure profile. Add tokens as below if you are testing it from soap and try.

com.ibm.SOAP.loginUserid=jde_admin
com.ibm.SOAP.loginPassword=password
 

kishorgite

Member
Log  diff F0011.jpg

We are unable to insert record into F0011 by BSFN when we call it from BSSV .
Do we need any specific authority or permission to insert data into F0011 .
Finally i have used username and password as JDE but still not working .

Regards
Kishor Gite
 

Lucky.2811

Active Member
This issue is been resolved.. Just to give update to everyone....

After analyzing log he provided, it is found that there is an insertion happening in F0011, and the same record is being fetched later. So if record insertion is successful then we wouldn't have issues in retrieving it. So it will take us to the concept of Transaction processing. As the whole process in the published BSSV is in the transaction processing all the transactions will be committed after closing the connection. But for this kind of scenario where the records will be fetched after insertion in the same transaction we need to explicitly do an AUTO/MANUAL commit. Here I suggested to use auto commit for the BSFN call , and it worked without issues.

If anyone has any questions on this let me know.
 
Top