E9.2 AIS Intermittent error for TIBCO Connection

Soumen

Reputable Poster
Dear List,

We are using a simple REST connection to TIBCO for an Orchestration. The orchestration runs fine most of the time but intermittently it fails with the below error. We have verified right at the time when we get this error that the REST connection is working testing through POSTMAN.

We have also confirmed the AIS server is up and running during the periods when it gave this error.


5060/4600 Fri Jan 7 11:22:54.493008 b98orch.c163
orchMgr->performRequest failed. AIS Response:
{"message":{"ServiceRequest: EW_CONT_INVOKE_TIBCO_REST_SALES_ORDER_ACK":{"statusCode":504,"error":"java.io.IOException: HTTPS hostname wrong: should be <snip>","headers":{}}},"exception":"Exception","timeStamp":"2022-01-07T11:22:53.746-0800","userDefinedErrorText":"","status":"ERROR"}

Error in AIS logs:

07 Jan 2022 11:22:53,723 [SEVERE] - [AIS] ExternalRestService generic httpRequest() java.io.IOException: HTTPS hostname wrong: should be <snio>
07 Jan 2022 11:22:53,745 [SEVERE] - [AIS] ExternalRestService - generic httpRequest() Failure - HTTP Request - Check AIS Server configuration in jas.ini java.io.IOException: HTTPS hostname wrong: should be <snip>
07 Jan 2022 11:22:53,745 [WARN ] - [AIS] ExternalRestService:callGeneric(): External Call Failed. java.io.IOException: HTTPS hostname wrong: should be <snip>


The orchstration is called using B98ORCH and we were able to capture some debug logs by submitting the UBE manually which cals the B98ORCH. You will notice the error above in the debug logs as well. Any clue what could be causing this error or anyone seen this before.

Thanks,
Soumen

E1 9.2
TR: 9.2.5.3, WebLogic 12c
 
Last edited by a moderator:
Top