Unable to invoke BSSV using SoapUI

Andrew2009

Well Known Member
I'm using JDE TR 9.1.04 and when I tried to invoke a BSSV published service using SoapUI 4.5.1, I got the below http error. Do you have any ideas?

Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "POST /PY910/PBS_OpportunityManager HTTP/1.1[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "Accept-Encoding: gzip,deflate[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "Content-Type: text/xml;charset=UTF-8[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "SOAPAction: "http://oracle.e1.bssv.JP57M052//getOpportunity"[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "Content-Length: 1092[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "Host: 10.1.1.143:8004[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "Connection: Keep-Alive[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "User-Agent: Apache-HttpClient/4.1.1 (java 1.5)[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "<soapenv:Envelope xmlns:java="java:eek:racle.e1.bssv.JP57M052.valueobject" xmlns:eek:rac="http://oracle.e1.bssv.JP57M052/" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">[\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> " <soapenv:Header><wsse:Security soapenv:mustUnderstand="1" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd"><wsse:UsernameToken wsu:Id="UsernameToken-13"><wsse:Username>testuser</wsse:Username><wsse:password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">testpassword</wsse:password><wsse:Nonce EncodingType="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-soap-message-security-1.0#Base64Binary">MT/v7sY2VIade/mBDzMa0Q==</wsse:Nonce><wsu:Created>2012-07-23T20:50:25.702Z</wsu:Created></wsse:UsernameToken></wsse:Security></soapenv:Header>[\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> " <soapenv:Body>[\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> " <orac:getOpportunityElement>[\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> " <java:OpportunityID>1</java:OpportunityID>[\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> " </orac:getOpportunityElement>[\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> " </soapenv:Body>[\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:>> "</soapenv:Envelope>"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "HTTP/1.1 500 Internal Server Error[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "Date: Mon, 23 Jul 2012 20:50:25 GMT[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "Transfer-Encoding: chunked[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "Content-Type: text/xml; charset=utf-8[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "X-Powered-By: Servlet/2.5 JSP/2.1[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "0163[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Header/><env:Body><env:Fault xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd"><faultcode>wsse:FailedAuthentication</faultcode><faultstring>Failed to assert identity with UsernameToken.</faultstring></env:Fault></env:Body></env:Envelope>"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "0000[\r][\n]"
Mon Jul 23 16:50:25 EDT 2012:DEBUG:<< "[\r][\n]"
 

gigi

VIP Member
If your bssv server is deployed to WebLogic server you have SSL connection so your link should be "https://....".
Inside Header you have specified user testuser. Is it a valid EnterpriseOne user ID?
You're bssv server must be started from EnterpriseOne Server Manager not from WLS console.
Deployng package with bssv to WLS server E1BSSVAuthenticator.jar has been deployed correctly to your WLS serevr (you should see a new authentication provider under "my realm" link on wls console)?

good luck
gg
 
Top