• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

QBE line grayed out

spuorro

Member
My client has an odd problem. In app P0006, all but 3 fields in the QBE/search field line at the top are grayed out. This only occurs in 2 environments - PY and QA. The fields are fine in DV and PD. JDE support has no clue so far so if anyone out there has any ideas, please post. Thanks so much.

Sondra
HP-UX 11, Oracle 8i, XE SP15 XU1

XE, SP15.1, HP-UX, Oracle 8.1.6
 

Zoltan_Gyimesi

Legendary Poster
Hi Sondra,

Check the OCM Mappings for the related User and/or Environment and/or Table. If the "Allow QBE" field on the bottom of the Object Mapping Revision is equal to 3 (Indexed fields QBE allowed) then change it to 1 (All QBE Allowed), hopefully this is the problem. If so, Log-off and Log-on OW to take effect the changes.

Filter for the related environments and check the following Object Name/Object Type/User Role entries if any:

* DEFAULT, TBLE, *PUBLIC
* F0006, TBLE, *PUBLIC
* DEFAULT, TBLE, UserID
* F0006, TBLE, UserID

If the User belongs to a User Group then make the same with the User ID of the User Group too.

Please, let us know your results. Thanks.

Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

spuorro

Member
Thanks a ton! This worked great. JDE is still clueless.

Sondra
XE SP15.1, HP-UX, Oracle 8i



XE, SP15.1, HP-UX, Oracle 8.1.6
 

ProjectRoom

Well Known Member
Re: RE: QBE line grayed out

I am using the application P42025 and all but 1 of the QBE line is grayed out, is this also a OCM setup?

I don't have security access to this (developers only do). What table has QBE allowed field set to 0, in otherwords what needs to be done to get the QBE line on teh P42025 activated?

Cheers

PR

[ B7.3.3.2 ][ SP 11.3 ][ NT 4.0 ][ AS/400 co-existance ]
 

Zoltan_Gyimesi

Legendary Poster
Re: RE: QBE line grayed out

Hi Project Room,

1.) If you have only few QBE fields grayed out then not only the OCM setting can cause it. If the grayed out fields do not come from the Business View of the grid instead of they are only Data Items and their values are derived (or computed) somehow from other fields/values then there is no way to QBE on it.
Briefly: You can QBE only on the fields that are comming from the Business View and can not on derived fields.

Here is an example:
* BSVW of the Grid contains QTY (Quantity) and UPRC (Unit Price) fields and they are on the grid.
* Developer place SPRC (Selling Price) Data Item on the grid to display the total price and make:
SPRC = QTY * UPRC
assignment ER statement somewhere but before the grid line appears.
Now, you can QBE on QTY and UPRC Business View fields but not on the derived SPRC field.

Hope, the explanation is clear.

2.) Sometimes not too hard to figure out which table resides behind a Form/Grid without access to FDA. I do not want to detail it here.

3.) "Allow QBE" field on OCM Revison Form do not accept 0 value, only:

1 - All QBE Allowed
2 - No QBE Allowed
3 - Indexed fields QBE allowed

To set the value to 2 or 3 could come from performance considarations.

Was it some answer to your questions?

Regards,
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 
Re: RE: QBE line grayed out

If I am not mistaken, if the field in the grid did not come from the
business view, the QBE line will always be greyed out on those fields.

Dan Eppich
The Anschutz Corporation
B7332 Coexistant, V4R5 w/central objects
INS Card deployment server
sp11.3, sp15.1 in Development
Optio DCS 6.3.2
Fat and Citrix over the Web



----Original Message Follows----
From: ProjectRoom <ProjectRoom@mailbomb.net>
Reply-To: jdelist@jdelist.com
To: jdelistml@jdelist.com
Subject: Re: RE: QBE line grayed out
Date: Fri, 17 Aug 2001 08:02:11 -0700 (PDT)

I am using the application P42025 and all but 1 of the QBE line is grayed
out, is this also a OCM setup?

I don't have security access to this (developers only do). What table has
QBE allowed field set to 0, in otherwords what needs to be done to get the
QBE line on teh P42025 activated?

Cheers

PR

[ B7.3.3.2 ][ SP 11.3 ][ NT 4.0 ][ AS/400 co-existance ]
--------------------------
Visit the forum to view this thread at:
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=&Board=OW&Number=19026
 

MKlehm

Member
Re: RE: QBE line grayed out

There are 3 reasons you might have a grayed out QBE field:

1) Derived or fetched field from another table (per Zoltan's description)
2) OCM setting
3) jde.ini setting - There is a setting found in the ini file that gray's
out QBE fields that are not indexed to protect users from themselves (i.e.
doing full table scans where no indexes exits)

-Mike Klehm

----- Original Message -----
From: "ProjectRoom" <ProjectRoom@mailbomb.net>
To: <jdelistml@jdelist.com>
Sent: Friday, August 17, 2001 10:02 AM
Subject: Re: RE: QBE line grayed out


out, is this also a OCM setup?
QBE allowed field set to 0, in otherwords what needs to be done to get the
QBE line on teh P42025 activated?
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=&Board=OW&Number=1
9026
 
Top