• JDELIST is celebrating its 20 year anniversary today!
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Error Deploying Update Package

Soumen

Reputable Poster
Dear All,

I am facing an issue in my DV client where while trying to deploy an update package it throws a message "Cannot deploy update package to Enterprise Server. The parent package has not been deployed.". I have made sure that the latest parent package is deployed on the client, also verified that the correct parent package has been selected while building the update package. Also checked the spec.ini for the correct entry. Compared the jde.ini with a working DV client machine.

I also noticed that while trying to deploy this same package on a different DV client machine it throws the same error. While if I try to deploy an update package which was built on a different DV client on this one it works. So that tells me something on the client is screwed up somewhere.

Any help will be very much appreciated.

Thanks,
Soumen
 

Tom_Davidson

VIP Member
Soumen,

What am I missing here, the message is about the ES not the Fat client. It appears the update package is not based on the current Full that is on your Enterprise server.

Also please include your configuration.

Tom
 

Soumen

Reputable Poster
Tom,

The Full package it is complaining about is deployed on the ES. I can deploy an update package to the same ES from any other DV client but not this one. So something is not working with this DV client.
We are on 9.1 (TR 9.1.4.7) on iSeries/WebSphere platform.
 

Tom_Davidson

VIP Member
Some strange things:

1) The server log doesn't even show an attempt to deploy.
2) Your fat client install is definitely suspect, lots of errors getting things (F983051, F00165, F98761)

If it was me, I'd take the Full again, and make sure it installs correctly (check the logs after the install)

Tom
 

Soumen

Reputable Poster
Ok. Just another note I tried to deploy the same package on a different client and it went past the screen where I got that error message. So definitely something wring with the client itself.
 

Soumen

Reputable Poster
Tom: Yes I am still getting these errors in the jde.log.
Jon: Our full package is just 2 weeks old.

I have opened a SR with Oracle to see what they say. I will keep the group posted if I hear anything interesting.


3796/6492 MAIN_THREAD Thu Jun 11 11:17:09.774000 Odbc_p1.c2044
ODB0000096 - SQLGetData failed. Table F983051, column VRPID, ODBC DSN Versions - DV910.

3796/6492 MAIN_THREAD Thu Jun 11 11:17:09.779000 Jdb_drvm.c1065
JDB9900172 - Failed to execute db fetch

3796/6492 MAIN_THREAD Thu Jun 11 11:17:09.799000 Odbc_p1.c2044
ODB0000096 - SQLGetData failed. Table F983051, column VRPID, ODBC DSN Versions - DV910.

3796/6492 MAIN_THREAD Thu Jun 11 11:17:09.805000 Jdb_drvm.c1065
JDB9900172 - Failed to execute db fetch

3796/6492 MAIN_THREAD Thu Jun 11 11:17:11.400000 Odbc_p1.c2044
ODB0000096 - SQLGetData failed. Table F983051, column VRPID, ODBC DSN Versions - DV910.
 

altquark

Legendary Poster
More than likely they will ask you to build and deploy a new full package. Certainly you should have done that anyway by now given the time of the original issue.
 
Top