• Welcome to the upgraded JDELIST forum and thank you for your patience.
    Please restrict discussions and issues regarding the new forum software to the Off Topic forum. We will be monitoring that forum for issues.
    If you have trouble logging in, please reset your password using the forgotten password form: https://www.jdelist.com/community/index.php?lost-password/
    If you are unable to successfully reset your password, please contact us: Click here!
    We hope that you enjoy the upgraded forum.
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

ER Debugger cannot connect to Broker in 8.97

jdeicon

Member
After upgrading our Tools Release to 8.97 we are on 8.11 we have been getting this error “ER Debugger cannot connect to Broker”

Note: It works on other machine that got upgraded
I uninstalled the Broker and installed it back. I even copied the related .JAR file from the Classes directory from a machine that works in case there was a mismatch. It stills no luck. Any suggestions are greatly appreciated. Below is the debug log error


“Unable to establish connection with Broker”

“Debugger initialization failed Unable to continue. See logs for more information.”
Debuglog error:
Oct 21 10:50:11.884010 - 1192/2076 FOREIGN_THREAD JDEJVM - optional jde.ini setting InProcessJVMHome in section [InProcessJVMHome] is blank or not provided. Attempting to load from bundled jvm inside of the system directory in c:\e811.

Oct 21 10:50:11.884011 - 1192/2076 FOREIGN_THREAD JDEJVM0000011 - JVM Home: c:\e811\system\JRE\1.4\bin\server\jvm.dll.

Oct 21 10:50:11.975000 - 1192/2076 FOREIGN_THREAD JDEJVM0000015 - Create JVM successfully. Return code is 0

Oct 21 10:50:12.005000 - 1192/2076 FOREIGN_THREAD JdeJvm::CheckForExceptions() - Java Exception encountered : java.lang.NoSuchMethodError: com.jdedwards.base.logging.JdeLog.getLogger(Ljava/lang/String;)Lcom/jdedwards/base/logging/Logger;

Oct 21 10:50:14.870000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:16.875000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:18.879000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:20.893000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:22.887000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:24.891000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:26.895000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:28.899000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:30.903000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:32.907000 - 1460/3944 MAIN_THREAD CBPMSocket::Connect(localhost, 9876) failed

Oct 21 10:50:32.907001 - 1460/3944 MAIN_THREAD CBPMConnector::doConnect could not connect to broker.

Oct 21 10:50:32.907002 - 1460/3944 MAIN_THREAD CBPMConnector::Connect could not connect to broker.

Oct 21 10:50:32.907003 - 1460/3944 MAIN_THREAD ER Debugger cannot connect to Broker.
 

Bbehrens

Member
We are having the same issue here. Users are able to logon, but the login process takes 15 - 30 seconds sometimes.

/String;)Lcom/jdedwards/base/logging/Logger;
Nov 07 06:57:43.967000 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:57:45.967001 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:57:47.967002 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:57:49.967003 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:57:51.967004 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:57:53.967005 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:57:55.967006 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:57:57.967007 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:57:59.967008 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:58:01.967009 - 4436/5356 FOREIGN_THREAD CBPMSocket::Connect(localhost, 9876) failed
Nov 07 06:58:01.967010 - 4436/5356 FOREIGN_THREAD CBPMConnector::doConnect could not connect to broker.
Nov 07 06:58:01.967011 - 4436/5356 FOREIGN_THREAD CBPMConnector::Connect could not connect to broker.
Nov 07 06:58:02.025000 - 4436/4636 MAIN_THREAD SE: Started the ERD Engine


Did you find a fix?
 

Malcolm

Member
I had a similar problem not so long ago. After much running around in circles, I discovered that the upgrade process does not clean up unused files in the system directory. I deleted the file bpm.jar and everything started working again.
 

prila1989

Member
Unable to establish connection with Broker - Standalone DEMO 9.01

Please can you help me resolve this issue.
I am getting error "Unable to establish connection with the broker".
I have registered the DLLs. Still I get the same issue.

Thanks
 
Version 8.11 tools relese 8.98.02.02.07
I spent all day with the oracle support, then here i found the simple solution.
I did the following step

1 Delete bpm.jar in
"C:\e811\system\classes" path
2 Open cmd ed run
regsvr32 C:\e811\system\bin32\E1Soap.dll
regsvr32 C:\e811\system\bin32\DebuggerService.dll
regsvr32 C:\e811\system\bin32\WinUBEDbgService.dll
regsvr32 C:\e811\system\bin32\JDEBPMSoap.dll
regsvr32 C:\e811\system\bin32\JDEBPMSockets.dll

Now it works well, I tried on 3 clients also, one with different jre and all works correctly.
Thanks!
MB
 
Top