Results 1 to 4 of 4

Thread: Arabic in Excel not showing correctly

  1. #1
    Member Rauf's Avatar
    Join Date
    Jan 2012
    Location
    Kerala, India
    Posts
    724

    Arabic in Excel not showing correctly

    Arabic text in Excel report output is not showing correctly (as attached). But it is okay in PDF. Do we need to do any settings so that the CSV file can hold Arabic text.
    Attached Images Attached Images
    RAUF
    JDE Techno-Functional
    JDE E1 8.12 | TR 8.96.40 | Windows XP SP 3

  2. #2
    Member
    Join Date
    Jun 2001
    Location
    Colorful Colorado
    Posts
    479
    Use the P93081 "work with flat file encoding" app to set the desired codepage for the output of the CSV for the report and version in question. CP1256 is Windows-Arabic. Or set it to UTF8, but Excel sometimes has issues with UTF8 on csv import.
    --john

  3. #3
    Member Rauf's Avatar
    Join Date
    Jan 2012
    Location
    Kerala, India
    Posts
    724
    This is already set. I also tried by making separate entry for the report name and version. But nothing worked.

    HTML Code:
    User /  Role	Environment	Program  ID	Version  	Encoding Name	Encoding Name  Description	Status  	Status  Description
    *PUBLIC	*ALL	*DEFAULT	*DEFAULT	CP1256	WIN-Arabic	AV	Active
    RAUF
    JDE Techno-Functional
    JDE E1 8.12 | TR 8.96.40 | Windows XP SP 3

  4. #4
    Member
    Join Date
    Jun 2001
    Location
    Colorful Colorado
    Posts
    479
    ah, I see you signature line -- 8.96 might be before they made UBE CSV export use that table, that is quite old.

    Turn on UBE Debug log at level 6, see if it is fetching an encoding from F93081. Make sure is is the same datasource/owner that the client is setting -- if server map points to a different table than client, you may not be finding the record.

    Also, if I recall correctly, your Windows user profile needs to be Arabic if you want Excel to recognize it as Arabic, independent of EOne.

    Try loading the CSV in Notepad, then select all, then pick Format->Font and pick Arial Or Times (or any font with Arabic script encoding support), and in the Script drop-down, pick "Arabic" and see if it renders. That could indicate that the CSV is ok, it is Excel that is freaking out.

    For Excel; Open Excel with a blank workbook. Click "Open" and then pick the CSV filename. If it just opens and doesn't ask you text import wizard questions, rename the file to .txt and try again. When you click "Open" and pick the file, in the Text Import Wizard, select File Origin dropdown setting of "1256: Arabic (Windows)" and see if it imports that way.
    Last edited by Segfault; 02-13-2020 at 01:59 PM.
    --john

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The legal restrictions and terms of use applicable to this site are available here.
Use of this site signifies your agreement to the terms of use.
JDELIST is NOT affiliated with JD Edwards® & Company, Oracle or Peoplesoft. Contents of this site are neither endorsed nor approved by JD Edwards® & Company and, or Oracle.