Results 1 to 4 of 4

Thread: Change Assistant Errors

  1. #1
    Senior Member craig_welton's Avatar
    Join Date
    Oct 2000
    Litchfield, CT
    1,037 Change Assistant Errors

    Hi all,

    I realize this is somewhat bleeding edge, but I keep getting errors when trying to deploy ESU packages in Change Assistant using TR


    2644/4896 WRK:Starting jdeCallObject         Tue Nov 26 10:03:55.730001 jdejvm.cpp2257
     JdeJvm::CheckForExceptions() - Java Exception encountered : java.lang.Exception: com.jdedwards.database.base.JDBException: [INTERNAL_ERROR] Internal error.
    2644/4896 WRK:Starting jdeCallObject         Tue Nov 26 10:03:55.738001 jdejvm.cpp2257
     JdeJvm::CheckForExceptions() - Stack Trace for Exception : java.lang.Exception: com.jdedwards.database.base.JDBException: [INTERNAL_ERROR] Internal error.
     at oracle.e1.database.copytablexml.E1CopyTableXML.initColumnInfoInternal(Unknown Source)
     at oracle.e1.database.copytablexml.E1CopyTableXML.initColumnInfo(Unknown Source)
     at oracle.e1.database.copytablexml.E1CopyTableXML.<init>(Unknown Source)
    Caused by: com.jdedwards.database.base.JDBException: [INTERNAL_ERROR] Internal error.
     at Source)
     at Source)
     at Source)
     at com.jdedwards.database.jdb.JDBSpecMapProxy.getSpec(Unknown Source)
     at com.jdedwards.database.impl.condensed.JDBSelectParameters.getCompositeTableSpecs(Unknown Source)
     at Source)
     at Source)
     at Source)
     at Source)
     at Source)
     at Source)
     at Source)
     at Source)
     ... 3 more
    Caused by: com.jdedwards.base.spec.SpecException: [WEBJITI_ERROR] Demand generation failed for DICT-LZRVN: {1}
     at Source)
     ... 16 more
    Caused by: com.jdedwards.database.base.JDBException: [WEBJITI_ERROR] Demand generation failed for DICT-LZRVN: null
     at Source)
     at Source)
     at Source)
     ... 17 more
    It works fine deploying the ESU package using the fat client app, so it seems java related.

    Once I change back to, it's fine. Dep server is x86 (haven't moved it to x64 yet). Tried with JRE 7 and 8.

    Anyone else?

    Last edited by craig_welton; 11-26-2019 at 09:28 AM.
    Craig Welton
    PatWel Group Inc.
    Home of the FREE JDE Object Browser, JDETrace, NERDup and BusBuild+ Tools

    E1 9.0 Wintel SQL 2008
    E1 9.2 iSeries

  2. #2
    Senior Member Alex_Pastuhov's Avatar
    Join Date
    Jul 2001
    From what I can see, CA is almost completely broken & useless now. I have Java (and I've tried 1.7.x too) and it's TR9241 for JDE and all CA can do for me is to find & download ESU's. It did not manage to install a single one and I've tried a few. So I'm back to manually doing it file by file ;-(

    I hope someone has a solution...
    Alexander Pastuhov

  3. #3
    We've run CA on with JRE jre1.8.0_221 without an issue.

  4. #4
    There is always something going on with CA. (mostly changes from Oracle) I called multiple times, they have no idea and no solution at all,
    What I have solved this kind of issue is to reinstall CA, JAVA latest version (kept the old Java), install VS 2017 distributor (to avoid other errors) (kept the old VS run time).



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
The legal restrictions and terms of use applicable to this site are available here.
Use of this site signifies your agreement to the terms of use.
JDELIST is NOT affiliated with JD Edwards® & Company, Oracle or Peoplesoft. Contents of this site are neither endorsed nor approved by JD Edwards® & Company and, or Oracle.