Results 1 to 4 of 4

Thread: Comma Values in XML File Causing Field to Repeat

  1. #1
    Member Mike Mackinnon's Avatar
    Join Date
    Nov 2000
    Location
    Halifax, Canada
    Posts
    182

    Comma Values in XML File Causing Field to Repeat

    Has anyone had a problem with the BI Publisher reporting where in the BI Publisher PDF report a value is repeating if there is either a space or a comma in the text field being outputted.
    For example: Customer Invoice Printing

    Mailing Name: NSHA Distribution Centre
    Address Line1: 109 Dorey Ave, Unit 1
    Address Line2: Burnside

    Displays in BI Publisher (and XML file) as:
    NSHA Distribution Centre
    NSHA Distribution Centre
    Burnside

    When we remove the comma from Address Line 2 it then prints properly. I am assuming there was some change when we went to JDE9.0 to JDE9.2 that there is a a bug.
    I am also looking on Oracle support to try and identify a bug but though I would post here as well. Thanks!

    * We are currently testing on JDE9.2, Tools Release: 9.2.2.6
    Mike MacKinnon
    IMP Group International
    EnterpriseOne tools RL 9.2.2.6, Application RL 9.2
    BI Desktop Publisher 11.1.1.7
    Browser IE10 & Chrome 62.0.3202.94

    - Financials, Inventory (Sales & Procurement), MRP, Manufacturing, Development Tools, BI Publisher

  2. #2
    Member
    Join Date
    Mar 2009
    Location
    Phoenix, AZ USA
    Posts
    59
    Mike, if the text "NSHA Distribution Centre" occurs in the source XML's <Address Line1> tag as well as the BIP output, then BIP is doing what it was told to do. But if the XML tag has the value "109 Dorey Ave, Unit 1", then it would be a problem with BI Publisher. Are you using an RTF template?
    - Kim
    Regards,
    Kim Schmidt

    - E1 9.1.4 ,TR 9.2.2 , iSeries, DB2
    - formerly Xe, 8.0, SQL Server, Oracle

  3. #3
    Member Mike Mackinnon's Avatar
    Join Date
    Nov 2000
    Location
    Halifax, Canada
    Posts
    182
    1.) It is appearing in the XML file as repeating. Thinking maybe it is a UBE/XML generation problem. I will go through the code again in UBE to check and maybe run DEBUG on this to inspect the values as program is running.
    2.) Yes RTF template.

    Thanks!
    Mike MacKinnon
    IMP Group International
    EnterpriseOne tools RL 9.2.2.6, Application RL 9.2
    BI Desktop Publisher 11.1.1.7
    Browser IE10 & Chrome 62.0.3202.94

    - Financials, Inventory (Sales & Procurement), MRP, Manufacturing, Development Tools, BI Publisher

  4. #4
    Member Mike Mackinnon's Avatar
    Join Date
    Nov 2000
    Location
    Halifax, Canada
    Posts
    182
    Turns out that I think this was a company constants setting that was maybe changed the way the BF handled the codes in the table.
    It's like 'blank' (which was our value) is not quite treated like the description from UDC anymore.

    The solution was to plug the value of "04" into the country constants instead of using the blank value (like we were doing) and it seemed to work.
    - Seems like the blank value is different in new release of 9.2.

    * Not a BI Publisher problem!
    Mike MacKinnon
    IMP Group International
    EnterpriseOne tools RL 9.2.2.6, Application RL 9.2
    BI Desktop Publisher 11.1.1.7
    Browser IE10 & Chrome 62.0.3202.94

    - Financials, Inventory (Sales & Procurement), MRP, Manufacturing, Development Tools, BI Publisher

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The legal restrictions and terms of use applicable to this site are available here.
Use of this site signifies your agreement to the terms of use.
JDELIST is NOT affiliated with JD Edwards® & Company, Oracle or Peoplesoft. Contents of this site are neither endorsed nor approved by JD Edwards® & Company and, or Oracle.