I have upgraded the tools release to 9.2.3.3 on my standalone which was at 9.2.0.1. I think everything is working EXCEPT busbuild. When it launches, it looks like it tries to build, but something is off. It doesn't actually compile the function. Here is a log from the busibuild. Below that is the Make file generated. It looked ok to me but I'm not familiar with the MAKE files. If I swap the SYSTEM back to the old one, everything works fine.

Microsoft Visual Studio Version being used: 9
Processing user defined build tools.

---------------- SafetyCheck Started ---------------

Scanning C:\E920\DEMO\include\B55GID.h...
Generating Makefile:
C:\E920\DEMO\obj\CCUSTOM.makScanning C:\E920\DEMO\source\B55GID.c...


---------------------- Done ----------------------

2 Files Processed
Makefile generated.

0 Errors
Building business functions for 32-bit.

0 Warnings


Thu Aug 8 09:04:25 2019

"c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\nmake.exe" /NOLOGO /k /c /a /s /f C:\E920\DEMO\obj\CCUSTOM.mak
************CCUSTOM************


Adjusting DLL load addresses . . .


************Build Finished************

CCUSTOM.dll - 0 error(s), 0 warning(s): Build failed. Restored previous dll.



************************************************** *****************************
# JD Edwards Make File For 32 bit Business Functions

# The PATH environment variable has been set to the following string:
# c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin;c:\Program Files (x86)\Microsoft Visual Studio 9.0\;C:\Program Files\Microsoft SDKs\Windows\v6.0A\bin;

TARGETOS=BOTH
OBJDIR=C:\E920\DEMO\obj
SRCDIR=C:\E920\DEMO\source
LIBRARY=C:\E920\DEMO\lib32\CCUSTOM.lib
DLLTARGET=C:\E920\DEMO\bin32\CCUSTOM.dll
SYSTEM=C:\E920\SYSTEM
APPINC=C:\E920\DEMO
STATICLIB=C:\E920\DEMO\lib32\sCCUSTOM.lib
STAGE1LIB=C:\E920\DEMO\lib32\1CCUSTOM.lib
EXPORTLIB=C:\E920\DEMO\lib32\CCUSTOM.exp
DUMPFILE=C:\E920\DEMO\obj\CCUSTOM.dmp
DEFFILE=C:\E920\DEMO\obj\CCUSTOM.def
OBJECTDLLMAIN=C:\E920\DEMO\obj\jdertdll.obj
APPLIB=C:\E920\DEMO


cflags= /Gz \
/Zp1 \
/Zi \
/W4 \
/MD \
/D "NDEBUG" \
/D "WIN32" \
/D "_WINDOWS" \
/D "UNICODE" \
/D "_UNICODE" \
/D "USESPECIALGPA4BB" \
/D "USETABLEHEADERFROMINCLUDEA" \
/D "_USE_32BIT_TIME_T" \
/nologo \
/I "$(APPINC)\include" \
/I "$(SYSTEM)\include" \
/I "c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\include" \
/I "c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\ATLMFC\include" \
/I "C:\Program Files\Microsoft SDKs\Windows\v6.0A\Include" \
/I "$(SYSTEM)\includev" \
/I "$(SYSTEM)\include\workflow" \
/I "$(SYSTEM)\include\jdesaw" \
/I "$(SYSTEM)\include\connector" \
/I "$(SYSTEM)\include\metadata" \
/I "$(SYSTEM)\include\xml" \
/c


# What we are building


all: $(DLLTARGET)

OBJECT =B55GID.obj \


OBJ = B55GID.obj
SOURCE = C:\E920\DEMO\source\B55GID.c
$(OBJ): $(SOURCE)
cl $(cflags) $(SOURCE) /Fo$(OBJ)


DLLMAINSOURCE = C:\E920\DEMO\work\jdertdll.c
$(OBJECTDLLMAIN): $(DLLMAINSOURCE)
cl $(cflags) $(DLLMAINSOURCE) /Fo$(OBJECTDLLMAIN)

linklibs=kernel32.lib \
user32.lib \
gdi32.lib \
shell32.lib \
comdlg32.lib \
msvcrt.lib \
jdel.lib \
jdbodbc.lib \
jdekrnl.lib \
jdeuser.lib \
jdegbr.lib \
odbc32.lib \
jdedia1.lib \
jdemail.lib \
envtool.lib \
browser.lib \
jdepkgbld.lib \
jdesetuputil.lib \
jdeunicode.lib \
jdeomw.lib \
owver.lib \
jdemtdeploy.lib \
jdenet.lib\
xmlcwrapper.lib\
xerceswrapper.lib\
rpcrt4.lib\
version.lib\
ODBCCP32.lib\
MSVCPRT.LIB\
V_verify.lib\
TCEngine.lib\
jdejvm.lib\
PTI.lib\
xmlpublisher.lib

# set linker options

linkflags= /DLL \
/DEBUG \
/SUBSYSTEM:windows \
/NODEFAULTLIB:LIBCMT.lib \
/NODEFAULTLIB:LIBCMTD.lib \
/NODEFAULTLIB:MSVCRT.lib \
/out:$(DLLTARGET) \
/FORCE:MULTIPLE \
/FORCE:UNRESOLVED \
/nologo \
/IMPLIB:$(LIBRARY) \
/MACHINE:X86 \
/INCREMENTAL:NO \
/DEF:$(DEFFILE) \
/LIBPATH:"C:\Windows\Microsoft.NET\Framework64\v4.0 .30319" \
/LIBPATH:"C:\Windows\Microsoft.NET\Framework64\v3.5 " \
/LIBPATH:"c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\LIB" \
/LIBPATH:"c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\ATLMFC\LIB" \
/LIBPATH:"C:\Program Files\Microsoft SDKs\Windows\v6.0A\lib" \
/LIBPATH:"$(SYSTEM)\lib32" \
/LIBPATH:"$(APPLIB)\lib32" \
/LIBPATH:"$(SYSTEM)\libV32"

.IGNORE:
$(STATICLIB): $(OBJECT)
lib.exe /NOLOGO /out:$(STATICLIB) $(STATICLIB) $(OBJECT)

$(DEFFILE): $(STATICLIB)
dumpbin /LINKERMEMBER:1 $(STATICLIB) > $(DUMPFILE)
C:\E920\SYSTEM\bin32\jdegenex $(DUMPFILE) $(DEFFILE)

$(EXPORTLIB): $(DEFFILE)

# Now build/update the dynamic link library

$(DLLTARGET): $(STATICLIB) $(OBJECTDLLMAIN) $(EXPORTLIB)
link @<<\CCUSTOM9.txt
$(linkflags) $(STATICLIB) $(OBJECTDLLMAIN) $(linklibs)
<<
mt.exe -manifest $(DLLTARGET).manifest -outputresource:$(DLLTARGET);#2