Results 1 to 1 of 1

Thread: Value not getting in Variable in BI (xml code)

  1. #1

    Value not getting in Variable in BI (xml code)

    I want to pass the "
    Quantity_ID10" value to the variable "
    PrintCpy" in BI publisher using xml code, and I used the following code

    <?if:Template_ID8='IPC'?>
    <?xdoxslt:set_variable($_XDOCTX,’PrintCpy’,Quantit y_ID10)?>
    <?for-each@section:xdoxslt:foreach_number($_XDOCTX,1,xdo xslt:get_variable($_XDOCTX,’PrintCpy’),1)?>
    <?call:imgctrl?>
    <?end for-each?>
    <?end if?>
    It shows error"Error invoking 'foreach_number':'java.lang.NumberFormatException" when giving the variable 'PrintCpy' but when giving quantity value instead of "
    PrintCpy"(<?for-each@section:xdoxslt:foreach_number($_XDOCTX,1,xdo xslt:get_variable($_XDOCTX,’2’),1)?>)
    it is Working
    .

    can anyone suggest a solution to get value in for loop..

    Last edited by sillajose; 03-14-2019 at 06:53 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The legal restrictions and terms of use applicable to this site are available here.
Use of this site signifies your agreement to the terms of use.
JDELIST is NOT affiliated with JD Edwards® & Company, Oracle or Peoplesoft. Contents of this site are neither endorsed nor approved by JD Edwards® & Company and, or Oracle.