Results 1 to 2 of 2

Thread: Integrated WebLogic Server WebService Testing problem

  1. #1

    Integrated WebLogic Server WebService Testing problem

    Hi everyone!

    I'm using "Oracle Hands on Lab JD Edwards BSSV Development" guide to develop BSSV and I faced with this trouble.
    I deployed my project on Integated WebLogic Server for testing purposes. The problem is that I could test my web service only once. The first test goes fine. When I changed web servive's arguments and click "Invoke" again I get an error (listed below). After Integrated Weblogic Server restart I could test my web service again but only once as mentioned before.
    If someone faced with such a problem could You give me some advice how to handle this?

    I'm using JDeveloper 12.1.3, Integrated Web Logic Server 12c and JD Edwards 9.2 Standalone
    Thanks in advance!


    "javax.xml.parsers.FactoryConfigurationError: Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found at javax.xml.parsers.FactoryFinder.newInstance(Factor yFinder.java:200) at javax.xml.parsers.FactoryFinder.newInstance(Factor yFinder.java:152) at javax.xml.parsers.FactoryFinder.find(FactoryFinder .java:232) at javax.xml.parsers.SAXParserFactory.newInstance(SAX ParserFactory.java:127) at com.sun.org.apache.xml.internal.resolver.Catalog.s etupReaders(Catalog.java:399) at weblogic.wsee.tools.xcatalog.WSEECatalogResolver.g etCatalog(WSEECatalogResolver.java:97) at weblogic.wsee.tools.xcatalog.XCatalogUtil.createRu ntimeCatalogResolver(XCatalogUtil.java:330) at weblogic.wsee.jaxws.spi.WLSServiceDelegate.staticC reateCatalogResolver(WLSServiceDelegate.java:174) at weblogic.wsee.jaxws.spi.WLSProvider.createServiceD elegate(WLSProvider.java:149) at weblogic.wsee.jaxws.spi.WLSProvider.createServiceD elegate(WLSProvider.java:131) at javax.xml.ws.Service.(Service.java:92) at javax.xml.ws.Service.create(Service.java:756) at com.oracle.webservices.testclient.core.ws.cdf.Engi ne.createService(Engine.java:141) at com.oracle.webservices.testclient.core.ws.cdf.Engi ne.getDispatch(Engine.java:100) at com.oracle.webservices.testclient.core.ws.cdf.SOAP BindingEngine.call(SOAPBindingEngine.java:57) at com.oracle.webservices.testclient.wstest.Invocatio nDelegate.invoke(InvocationDelegate.java:46) at com.oracle.webservices.testclient.wstest.WsTestCal ler.invokeOpertion(WsTestCaller.java:95) at com.oracle.webservices.testclient.ws.action.WsInvo keAction.execute(WsInvokeAction.java:67) at com.oracle.webservices.testclient.ws.action.Abstra ctAction.process(AbstractAction.java:36) at com.oracle.webservices.testclient.ws.res.Webservic eResource.invokeWebService(WebserviceResource.java :206) at com.oracle.webservices.testclient.ws.res.Webservic eResource.invokeWebServiceByFormURLEncoded(Webserv iceResource.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at com.sun.jersey.spi.container.JavaMethodInvokerFact ory$1.invoke(JavaMethodInvokerFactory.java:60) at com.sun.jersey.server.impl.model.method.dispatch.A bstractResourceMethodDispatchProvider$TypeOutInvok er._dispatch(AbstractResourceMethodDispatchProvide r.java:185) at com.sun.jersey.server.impl.model.method.dispatch.R esourceJavaMethodDispatcher.dispatch(ResourceJavaM ethodDispatcher.java:75) at com.sun.jersey.server.impl.uri.rules.HttpMethodRul e.accept(HttpMethodRule.java:302) at com.sun.jersey.server.impl.uri.rules.RightHandPath Rule.accept(RightHandPathRule.java:147) at com.sun.jersey.server.impl.uri.rules.ResourceClass Rule.accept(ResourceClassRule.java:108) at com.sun.jersey.server.impl.uri.rules.RightHandPath Rule.accept(RightHandPathRule.java:147) at com.sun.jersey.server.impl.uri.rules.RootResourceC lassesRule.accept(RootResourceClassesRule.java:84) at com.sun.jersey.server.impl.application.WebApplicat ionImpl._handleRequest(WebApplicationImpl.java:154 2) at com.sun.jersey.server.impl.application.WebApplicat ionImpl._handleRequest(WebApplicationImpl.java:147 3) at com.sun.jersey.server.impl.application.WebApplicat ionImpl.handleRequest(WebApplicationImpl.java:1419 ) at com.sun.jersey.server.impl.application.WebApplicat ionImpl.handleRequest(WebApplicationImpl.java:1409 ) at com.sun.jersey.spi.container.servlet.WebComponent. service(WebComponent.java:409) at com.sun.jersey.spi.container.servlet.ServletContai ner.service(ServletContainer.java:540) at com.sun.jersey.spi.container.servlet.ServletContai ner.service(ServletContainer.java:715) at javax.servlet.http.HttpServlet.service(HttpServlet .java:844) at weblogic.servlet.internal.StubSecurityHelper$Servl etServiceAction.run(StubSecurityHelper.java:280) at weblogic.servlet.internal.StubSecurityHelper$Servl etServiceAction.run(StubSecurityHelper.java:254) at weblogic.servlet.internal.StubSecurityHelper.invok eServlet(StubSecurityHelper.java:136) at weblogic.servlet.internal.ServletStubImpl.execute( ServletStubImpl.java:346) at weblogic.servlet.internal.TailFilter.doFilter(Tail Filter.java:25) at weblogic.servlet.internal.FilterChainImpl.doFilter (FilterChainImpl.java:79) at com.oracle.webservices.testclient.web.LocaleFilter .doFilter(LocaleFilter.java:25) at weblogic.servlet.internal.FilterChainImpl.doFilter (FilterChainImpl.java:79) at com.oracle.webservices.testclient.wlsweb.TestPageA ccessFilter.doFilter(TestPageAccessFilter.java:43) at weblogic.servlet.internal.FilterChainImpl.doFilter (FilterChainImpl.java:79) at weblogic.servlet.internal.WebAppServletContext$Ser vletInvocationAction.wrapRun(WebAppServletContext. java:3436) at weblogic.servlet.internal.WebAppServletContext$Ser vletInvocationAction.run(WebAppServletContext.java :3402) at weblogic.security.acl.internal.AuthenticatedSubjec t.doAs(AuthenticatedSubject.java:321) at weblogic.security.service.SecurityManager.runAs(Se curityManager.java:120) at weblogic.servlet.provider.WlsSubjectHandle.run(Wls SubjectHandle.java:57) at weblogic.servlet.internal.WebAppServletContext.doS ecuredExecute(WebAppServletContext.java:2285) at weblogic.servlet.internal.WebAppServletContext.sec uredExecute(WebAppServletContext.java:2201) at weblogic.servlet.internal.WebAppServletContext.exe cute(WebAppServletContext.java:2179) at weblogic.servlet.internal.ServletRequestImpl.run(S ervletRequestImpl.java:1572) at weblogic.servlet.provider.ContainerSupportProvider Impl$WlsRequestExecutor.run(ContainerSupportProvid erImpl.java:255) at weblogic.work.ExecuteThread.execute(ExecuteThread. java:311) at weblogic.work.ExecuteThread.run(ExecuteThread.java :263) Caused by: java.lang.ClassNotFoundException: org/apache/xerces/jaxp/SAXParserFactoryImpl at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:348) at javax.xml.parsers.FactoryFinder.getProviderClass(F actoryFinder.java:124) at javax.xml.parsers.FactoryFinder.newInstance(Factor yFinder.java:188) ... 62 more "

  2. #2
    I had a slightly similar issue and an answer here would've made my day. Unfortunately there was no answer but I did workaround the issue myself and I'll explain that story now.

    I first worked around this issue in October with 12.1.3 but spaced out what I did today encountering the issue using 12.2.1.

    My issue was a similar error and similar circumstance of running JDE in WLS. It ran fine once then wouldn't run later. (I received the error you did when trying to undeploy my bad JDE deployment within the WLS console.)

    The tweak I made was to WLS and is along the lines of what you can see here:

    http://publib.boulder.ibm.com/tividd...install177.htm

    My exact steps:
    1) Find my startWebLogic.cmd file, that for me was here: C:\Users\lees@jde\AppData\Roaming\JDeveloper\syste m12.2.1.0.42.151011.0031\DefaultDomain\bin.
    2) Replaced "set CLASSPATH=%SAVE_CLASSPATH%" with "set CLASSPATH=%SAVE_CLASSPATH%;C:\Oracle\JDeveloper122 1\Oracle_Home\oracle_common\modules\oracle.owasp\x ercesImpl.jar" (not sure how I picked this magical JAR--I have a bunch of them on my box but am going with this one for no remembered reason).
    3) Restarted my WLS (and in my case, removed the bad deployment, re-deployed, and off I go).

    Note that my caveat to this reply is that this tweak helps me continue working. It might not be the best idea or appropriate but it's working for me so I'll go with it. Maybe it'll help you if you still have a problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The legal restrictions and terms of use applicable to this site are available here.
Use of this site signifies your agreement to the terms of use.
JDELIST is NOT affiliated with JD Edwards® & Company, Oracle or Peoplesoft. Contents of this site are neither endorsed nor approved by JD Edwards® & Company and, or Oracle.