nice i did all that for nothing actually i tried to install 9.1 and it failed because it is not compatible with win 8.1 apparently, I will now try the 9.2.