Results 1 to 8 of 8

Thread: Maximum number of users exceeded

  1. #1
    Member Tom_Davidson's Avatar
    Join Date
    Nov 2000
    Location
    Wisconsin, USA
    Posts
    758

    Maximum number of users exceeded

    I am getting this message in my JDE log on the JAS server: JASException occured in the JDESignon.isMaxUserExceed():Maximum user limit exceeded OneWorld Error: 222, level: 1 OneWorld Error: 222, level: 1: mError: JASERR

    I have the max number of users set to 100, and SM shows I have 100 users attached. But when I look at active sessions I only had about 15 active sessions. I have been watching this for a while and it seems like the number of sessions slowly rises over time. This took 59 days to reach the maximum.

    I have looked on MOS and apparently are not searching correctly. Has anyone else run into this issue?

    Thanks.

    Tom Davidson
    Tools 8.98.4.4 OAS. E8.12
    AS/400 ES, Windows JAS server 2008R2

    Cleindori Consulting
    8.12/8.98.4.14, 9.1/9.1.5.3, 9.2/9.2.0.5/6
    IBM i, WebLogic on Windows, DBCS, Global installations.

  2. #2
    Member
    Join Date
    Apr 2006
    Location
    Oz
    Posts
    108

    Re: Maximum number of users exceeded

    Haven't faced this issue but it might be related to Security Kernel not releasing "stale" users i.e. the inactive users are still clinging onto the kernel making the no of users attached to security kernel grow. It does impact the memory but the impact is very less.

    Probably there was a fix that was released for this (tools fix)

    -Max

  3. #3
    Member Tom_Davidson's Avatar
    Join Date
    Nov 2000
    Location
    Wisconsin, USA
    Posts
    758

    Re: Maximum number of users exceeded

    Max,

    Thanks for the input. But I don't think it has to do with the security kernel, as I am running multiple security kernels. Recycling the JAS instance clears the count, I think it is something in the JAS instance itself.

    Any other ideas would be appreciated.

    Tom
    Cleindori Consulting
    8.12/8.98.4.14, 9.1/9.1.5.3, 9.2/9.2.0.5/6
    IBM i, WebLogic on Windows, DBCS, Global installations.

  4. #4
    Senior Member altquark's Avatar
    Join Date
    Oct 2000
    Location
    Kansas City, MO
    Posts
    2,641

    Re: Maximum number of users exceeded

    Hi Tom

    I've seen this before. I think its got something to do with the tools release you're on - 8.98 - although looking at your version - you might be stuck on that tools release.

    Alternatively, you COULD jut try updating the SMC and agents to a newer version - recycling the JAS server is resetting the user count, but it might be that the "log out" on the JAS server isn't always dropping the total number of users.

    By the way, I would expect that this is due to user behaviour as well. I would put money on the fact your phantom users are either the result of a closure of IE instead of log out - or maybe its a timeout (which would be modifiable through your timeout settings). Its not for every user, since no doubt you'd see this a lot faster than 57 days.

    Lastly, you COULD just reset your JAS instances once per week !!!!
    Jon Steel
    EnterpriseOne/SOA Technical Architect
    erpSOURCING LLC
    http://www.erpsourcing.com
    cto@spla.sh
    24/7 Assistance - (904) 382 5701

  5. #5

    Re: Maximum number of users exceeded

    To add to Jon's point about users closing out the browser rather than using the "log out" option , check your JAS.INI and check for the LogOutOnBrowserClose parameter , it is true by default though and I have verified that it does work. I am looking at a system on a 9.1 tools release though, but I believe this setting is there in 8.98 also
    EnterpriseOne Xe to 9.2
    Windows/ Unix / AS400
    Oracle , SQL Server, DB2
    WAS , WLS
    AppWorx, Tidal , SmartScheduler

  6. #6
    Member Tom_Davidson's Avatar
    Join Date
    Nov 2000
    Location
    Wisconsin, USA
    Posts
    758

    Re: Maximum number of users exceeded

    Jon & Ice,

    I too think it is probably due to user behavior, and closing the browser, we do have log out on browser close set to true, but I suspect that it isn't executed when the user issues 'shutdown' I've tried it on my PC but haven't been able to duplicate it, but with the different OS's and browsers out there, I'm not necessarily shocked that I can't.

    I could go to 8.98.4.11, and am thinking of doing so, hoping that this will solve the issue. I didn't have it in 8.98.4.2

    Thanks for the input.

    Tom
    Thanks for the input.
    Cleindori Consulting
    8.12/8.98.4.14, 9.1/9.1.5.3, 9.2/9.2.0.5/6
    IBM i, WebLogic on Windows, DBCS, Global installations.

  7. #7

    Re: Maximum number of users exceeded

    Found this:
    The reason we got this error is a bug in Windows Server 2008 R2 / Windows 7. The kernel leaks loopback sockets due to a race condition on machines with more than one core, this patch fixes the issue: http://support.microsoft.com/kb/2577795

    URL is:
    http://stackoverflow.com/questions/1...ctions-reached

  8. #8
    New Member
    Join Date
    May 2008
    Location
    U.A.E
    Posts
    3

    Smile Session Time out settings

    If you refer E1: JAS: Best Practices on Setting User Session Timeout Value for HTML Server ( JAS ) Instance Configured on Any Application Server (Doc ID 1488013.1)

    I. Application Server Timeout

    For WLS, the application server timeout values are directly updated in web.xml(s) file.

    Locate the two web.xml files for the Weblogic installation as given below:

    .web.xml in the Server Manager Agent installation directory where JAS instance is configured:

    ......targets/<webinstance name>/owl_deployment/webclient.ear/app/webclient.war/WEB-INF/web.xml

    .web.xml in the Weblogic installation directory:

    ......user_projects/domains/.../servers/machine name/stage/<webinstance name>/app/webclient.war/WEB-INF/web.xml

    Make a backup of the above two web.xml files. Add the following stanza at the end (right before </web-app>) of both these web.xml files:

    <session-config>
    <session-timeout>9</session-timeout>
    </session-config>


    NOTE: The time values defined in web.xml file is measured in minutes.


    Restart the JAS instance once.



    II. Update the UserSession value in the relevant JAS.INI

    Use Server Manager Console to update the parameter UserSession in the JAS.INI file:

    Login to Server Manager Console.
    Navigate to the Managed Instance page for the HTML server.
    Change the View to "Advanced" under Configuration pane.
    Select Cache and update the parameter "User Session Cache Timeout" to desired value. The User Session Cache Timeout value will need to be entered as milliseconds (e.g. 1800000 for 30 minutes, 3600000 for 1 hour) - 600000.

    E1: JAS: Best Practices on Setting User Session Timeout Value for HTML Server ( JAS ) Instance Configured on Any Application Server (Doc ID 1488013.1)

    Quote Originally Posted by higgs312 View Post
    Found this:
    The reason we got this error is a bug in Windows Server 2008 R2 / Windows 7. The kernel leaks loopback sockets due to a race condition on machines with more than one core, this patch fixes the issue: http://support.microsoft.com/kb/2577795

    URL is:
    http://stackoverflow.com/questions/1...ctions-reached

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The legal restrictions and terms of use applicable to this site are available here.
Use of this site signifies your agreement to the terms of use.
JDELIST is NOT affiliated with JD Edwards® & Company, Oracle or Peoplesoft. Contents of this site are neither endorsed nor approved by JD Edwards® & Company and, or Oracle.