Results 1 to 8 of 8

Thread: UTBrowse.exe failure to launch

  1. #1
    New Member
    Join Date
    May 2008
    Posts
    15

    UTBrowse.exe failure to launch

    Folks,
    We have just installed some new citrix servers with metafreame 4.5. The E1 part seems to be working fine but when we try to launch utb all we get is the following error:
    UTBRowse.exe - application error
    The Application Failed to initialize properley(0XC06d007e). Click OK to terminate the application

    We get this error when we launch utb from the E1 published app(Fastpath) and when we published utbrowse.exe by itself.
    This issue occurs with IE and FireFox


    If we log on to the console of the terminal server we do not have an issue at all.

    Has anyone seen this issue before?
    Jane
    E1 8.10 tools 8.94
    AS400 DB2


  2. #2

    Re: UTBrowse.exe failure to launch

    Do you get the same error when you login with the same Windows user via published app (I assume seamless window) and when you login "full" (custom connection using Program Neighborhood)?

    Cheers,

  3. #3
    Senior Member
    Join Date
    Mar 2002
    Location
    Seal Beach, CA
    Posts
    1,319

    Re: UTBrowse.exe failure to launch

    If I remember correctly (somebody please correct me if I'm wrong), but UTB is considered a development tool, and will refuse to run in a Terminal Services/Citrix session.

    Try adding OWDEVELOPER=TRUE in your JDE.INI under [DEBUG], and then test it. You'll want to try it in your profile's copy of JDE.INI, rather than in the central JDE.INI in C:\WINDOWS.

    You must be really careful with this, as that flags allows OMW use, and full check-in/check-out under Terminal Services/Citrix. I have to ask if UTB access is really necessary for users ...
    Ken Wong
    Certified in CNC Implementation and Oracle Cloud Architect
    B73.1.1 through E920
    DB2/400, Oracle, SQL Server
    AS/400, Linux, Windows, Citrix, OAS/WebLogic, WebSphere
    AIS, One View, Orchestrator, UPK
    VMWare, AWS, Azure, Oracle Cloud

  4. #4
    New Member
    Join Date
    May 2008
    Posts
    15

    Re: UTBrowse.exe failure to launch

    Thanks for you post, I do get there error using both ways to access the application

  5. #5
    New Member
    Join Date
    May 2008
    Posts
    15

    Re: UTBrowse.exe failure to launch

    Thank you for your note. We do allow our users to use UTB from the citrix environment and it is working on the current servers but, since we installed the new servers, we have not been able to get it to function. I tried adding the OWDEVELOPER=TRUE but that did not fix the issue

  6. #6
    Senior Member Larry_Jones's Avatar
    Join Date
    Nov 2000
    Location
    Spokane, WA, USA
    Posts
    3,267

    Re: UTBrowse.exe failure to launch

    Jane,

    after launching UTB, wait 30 seconds before attempting to open/view a table and see if it behaves differently. On an older Tools Release level we had an issue similiar to what you describe on TSE. If we waited a few seconds before attempting to open/view anything the problem would not appear. Problem was corrected by upgrading the Tools Release.

    Cheers,
    Larry Jones
    E1 9.2 - TR 9.2.2.6 on Win 2016 R2. SQL Server 2016
    Wintel, BI Publisher

  7. #7

    Re: UTBrowse.exe failure to launch

    My guess would be Windows permissions (physical files and/or registry) or maybe policy. Either way, Windows would throw errors in Event Viewer.

    I would make sure group Remote Desktop Users group (or Authenticated Users group) has full access to E810 folder, then use regmon while launching UTBrowse.exe to see if there are any violations.

    Cheers,

  8. #8
    New Member
    Join Date
    May 2008
    Posts
    15

    Re: UTBrowse.exe failure to launch - resolution

    Just wanted to followup on this issue, there is a fix for citrix for this very issue Citrix Hotfix PSE450R02W2K3007. However it was not availble to the general public had to contact a citrix partner

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The legal restrictions and terms of use applicable to this site are available here.
Use of this site signifies your agreement to the terms of use.
JDELIST is NOT affiliated with JD Edwards® & Company, Oracle or Peoplesoft. Contents of this site are neither endorsed nor approved by JD Edwards® & Company and, or Oracle.