Results 1 to 6 of 6

Thread: OneWorld/Oracle Question

  1. #1

    OneWorld/Oracle Question

    We are using XE and have ERP 8 in testing. I want to copy all the secuirty information from XE to ERP 8. When I try to insert the F98OWSEC records from XE to ERP 8 by using INSERT INTO SYS7334.F98OWSEC SELECT * FROM SYS7333.F98OWSEC - I get the error ORA-00997: illegal use of LONG datatype. What is another way of doing this?? Thanks!

    Melissa
    ERP 8 SP22 Oracle on SUN (Win2000 Apps Server)

  2. #2
    Senior Member DSauve's Avatar
    Join Date
    Nov 2000
    Location
    Spokane, WA
    Posts
    1,248

    Re: OneWorld/Oracle Question

    You may want to try using an Oracle Export to export from the SYS7333 tablespace, and then use an Oracle Import to import it into SYS7334 tablespace.
    Don Sauve
    Wagstaff, Inc.
    E1 9.2, Win2016, SQL Server 2016, TR 9.2.2.6, WebLogic 12.2.1, BI Publisher

  3. #3
    Member
    Join Date
    Mar 2002
    Location
    Plano, TX
    Posts
    63

    Re: OneWorld/Oracle Question

    Don't remember the Oracle syntax, but I believe you need to use the VarChar.
    JDE E1 9.0 (8.98.4.11)
    Windows/SQL
    GL, AP, AR, FA, Budget, Inventory, Purchasing. Working on Expense Management

  4. #4
    Senior Member
    Join Date
    Sep 2001
    Location
    CA, USA
    Posts
    243

    Re: OneWorld/Oracle Question

    The syntax is right. BUT you can copy the tables with long type column using this syntax

    Try copy .. append command from sqlplus
    e.g
    copy from user/password@abc to user/password@xyz
    append target_table using select * from source_table;

    Hope this help
    Vivek Mohan
    Update 3, Service Pack 23
    SQL Server 7
    Windows 2000 Enterprise Server
    Thin and Fat clients

  5. #5

    RE: OneWorld/Oracle Question

    Hello, Melissa,
    Use table export/import. If you need the syntax, let me know.
    Are these two tables identical?

    Regards, Alex Shevchenko

    XE SP18 Oracle 8.1.7, Solaris production
    XE SP18 Oracle 8.1.7, Solaris test


  6. #6

    Re: OneWorld/Oracle Question

    Thanks for the suggestion. This acutally worked to move the data but for some reason JDE didn't like it and when I tried to log in - told me that the accounts had been disable. But thanks for the suggestion because I have found other uses for COPY. Thanks!
    Melissa
    ERP 8 SP22 Oracle on SUN (Win2000 Apps Server)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
The legal restrictions and terms of use applicable to this site are available here.
Use of this site signifies your agreement to the terms of use.
JDELIST is NOT affiliated with JD Edwards® & Company, Oracle or Peoplesoft. Contents of this site are neither endorsed nor approved by JD Edwards® & Company and, or Oracle.