• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

XT4113Z1 - F4113 FS EndDoc Issue not completing all the transaction lines.

IvanGRMseak

Member
[FONT=&quot]Hello List, Before anything I just want to appreciate the time you are taking to read this question. Also noting that I have searched in the forum for a problem not identical, but similar in a way that maybe its happening to another person but with other MBF but I have found nothing so far. Having said that:

Ok so im creating a custom Interactive Version where the user can do multiple inventory transfers within our custom form. For this I am using the XT4113Z1 BSFN (Begin doc, Edit Line, End Doc, Clear cache). the code is already set and I started with 1 transfer and it was successfully completed (Kardex transactions and IT document were created correctly).

So then I escalated to the Multiple Line Processing and entered 2 Item transfers at once and the process seamed to finish just fine with out any errors (just the usual warning telling you that the date is in a future fiscal year) EXCEPT of course, that the Inventory transfer (when checked in the P4113) was missing 1 line.

Example:

Data In:
Item 1: 2601 - from MCU: 141 - LOCN from: TE.ST.1 - To MCU: 141 - LOCN to: TE.ST.2

Item 2: 2701 - from MCU: 142 - LOCN from: TE.ST.1 - To MCU: 142 - LOCN to: TE.ST.2

Result in P4113:

Batch No.: 9342 = Item 2: 2701 - from MCU: 142 - LOCN from: TE.ST.1 - To MCU: 142 - LOCN to: TE.ST.2



I then tried to do it with 3 Items and got the same result, just 1 transfer was registered and I noticed after some more testing that the transfers that are aways successful, are just the last ones. I don't Know where to start even debugging as the system shows no error at all. but the functionality is just wrong. at the end of the process I should have 1 batch number and 2 inventory transfers under that Batch number; but no matter how many different Inventory movements I send to the F4113 FS Edit Line, the F4113 FS End Doc ALWAYS, ALWAYS commits the last Inventory transfer stored in cache.

Have you ever encountered and Issue similar to this with Cache functions? any Ideas how to identify the issue?

Attached is the ER of the event in charge of the magic.

JDE version is 9.2
Tool release 9.2
RedHat Enterprise Linux 7
Oracle 12 C DB[/FONT]
 

Attachments

Last edited by a moderator:

craig_welton

Legendary Poster
Hi Ivan,

While I can't give you a specific answer, this may help you ... I had a similar issue when automating transfers. Perform the multi line transfer in the interactive application (P4113), but before you start, turn on tracing (jdedebug.log). After completing, analyze the log to see the parameters being sent to EditLine. Iirc, there are several line number parms that must be set just right for it all to work. Some you will have to increase manually, others reset etc. There is a free tool called JDETrace that can be helpful when working with the debug log.

Craig
 

IvanGRMseak

Member
Hi Craig,

Thank you so much for your reply. I have being debugging manually (not with logs) the P4113 for about 2 days now and now that I read your reply, some of my suspicions regarding specific variabales were kind of answered.

Now that you mention it, I was paying close attention to the Journal Entry Last Line variable and noticed that the P4113 always retrieves the last journal entry line before stepping into the Edit Line function. Then I checked my code and debug it and noticed that my Journal entry line was always retrieved as "0" from the -Edit line- Function. Im starting to think that I should always manually get that value as my problem may be coming from the BSFN thinking that the Journal entry last line is always Zero and then it proceeds to overwrite the last 2 records it wrote...

Im going to continue working on this and update if I find the answer or anything at all.

Regards.
 
Top