• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

XE RDA not WYSIWYG?

Frosty the Coder

Legendary Poster
List,

I thought this had been discussed before, but could not find it
doing a search on "wysiwyg" (what you see is what you get).

Under XE, sp13, I'm modifying the pick slips to include 6
blocks of shipto name/addrs.

Visually, w/in the RDA, the layout looks the same for each
block. When I run and/or preview the pickslip, the alignment
changes so that name and addr1 overlap in 3 of the blocks.

If I add more space between the lines, I get the addl space,
but when I put it back to the "correct" spacing, I again get
overlap.

Am I doing something wrong when designing this mod?

Is there a way, using the ALIGN function to align
"the top of this field to the bottom of that field"?

TIA

Gene



Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
AS/400, B733, SP14, W2000 client
XE, SP13
 

Stewart

Active Member
Gene,
This sounds similar to a problem I had back in March. It's in the developers forum under "Line Spacing for Reports". Johan Rehn came up with the answer to my problem. The two reasons I was getting unequal line spacing were:
1. The fields were overlapping - it is best to make sure the corner markers of the fields are not touching or overlapping.
2. There were hidden fields which were close to, or overlapping the ones being displayed. I eventually moved all the hidden fields outside the printable area of the page.
These solved my problem, hope they help you

Regards,

Stewart
Customer: Xe/NT/Oracle
Office: B7331/NT/SQL
 

Frosty the Coder

Legendary Poster
Stewart,

Thanks.

I'm sure that there are hidden fields, w/in the RDA, causing my problem.




Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
AS/400, B733, SP14, W2000 client
XE, SP13
 
Top