• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

World Writer Buffer length?

Frosty the Coder

Legendary Poster
I copied an existing WW that creates an output file.

I modified my copy, dropping several columns from output, changing data selection, etc.
When I run the world writer, it abends stating that the record length (172) is less than
the buffer length 32000.

I've looked at the output specs and have only those columns that I want which does produce a record of 172 characters.

Where/what is the "buffer" that is causing me issues?

Thanks
 

Attachments

Frosty the Coder

Legendary Poster
After digging at the joblogs and program dumps, I decided to create a "from scratch" World Writer,
having the same tables, columns, data selections, sort, totaling, etc as that I had copied from.

The "from scratch" version works w/out blowing up.

As far as WHY the copy didn't work, and the "from scratch" did, I find myself both ignorant and apathetic.
That's right, I don't know and I don't care.
(I'm feeling a bit jaded on this Friday afternoon).

Thanks
 

TerryWin

Well Known Member
Disclaimer: I have never worked with WorldWriters...

But...I would look at the file description: DSPFD JDEQUERY/MSRUNVOUCH

QDBOPEN is the standard DB2 function to open a physical file. It could be possible that the WW routines did not perform an OVRDBF, or maybe the file was created/duplicated incorrectly, etc.

There are also a couple of PTF's open for QDBOPEN depending on the release level - unfortunately they don't really look to be applicable based on your screen shot.
 
Top