• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Weird busbuild link error - unresolved external symbol _GPoolCommon

BOster

Legendary Poster
TR9.2

I occasionally have this busbuild error when building BSFNs on TR9.2x.

Example:
Code:
Microsoft Visual Studio Version being used: 2017
Processing user defined build tools.

---------------- SafetyCheck Started ---------------
Scanning C:\E920\DV920\include\B4200311.h...


Scanning C:\E920\DV920\source\B4200311.c...Generating Makefile:  
C:\E920\DV920\obj\CSALES.mak
---------------------- Done ----------------------

2 Files Processed

0 ErrorsMakefile generated.


0 WarningsBuilding business functions for 32-bit. 




Tue Jan 21 17:11:07 2020

"C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Tools\MSVC\14.16.27023\bin\Hostx86\x86\nmake.exe" /NOLOGO /k /c /a  /s  /f C:\E920\DV920\obj\CSALES.mak
************CSALES************

B4200311.c
Replacing B4200311.obj
jdertdll.c
CSALES.def : error LNK2001: unresolved external symbol _GPoolCommon
C:\E920\DV920\lib32\CSALES.lib : fatal error LNK1120: 1 unresolved externals

Adjusting DLL load addresses . . .


************Build Finished************

CSALES.dll   -   2 error(s),    0 warning(s):  Build forced to complete with errors.
If I simply re-click the build button the error goes away (no change in code). If I click build again, the error shows back up, click build again and the error goes away. Its like the error pops up every other time I build the same BSFN. Anyone else ever see this?
 
Top